License not validating


I recently migrated my site from one domain to another and now the X theme validation doesn’t validate no matter how many times I manually enter my code.

It temporarily says the product is validated but if I navigate to any other part of the WordPress admin pages and back to the X theme validation page, it shows I need to validate again.

I’ve ensured that both my previous domain (my staging) and the newly migrated one (production) is entered.

My staging site has no issues, just the production.

Please advise.

Hello Eric,

Thanks for writing in! Can you please confirm that you have updated to the latest versions?
Our latest versions are:

  • X theme 6.4.5
  • Cornerstone 3.4.5

This latest release contains fixes for several issues so be sure to check out the changelog (

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

​To validate X properly, please do the following:
1] Please login to your APEX account and assign the license here: You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Validation and insert the license again.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

Please let us know how it goes.


i’ve done all of that.

  1. i’ve already added the url to the license
  2. I’ve entered the license into the validation. It “succeeds” but as i mentioned, once i refresh or navigate and come back, it goes back to an unvalidated state.

Hi Eric,

Do you have memory caching or database caching in your production site? The validation works, it just not saved to your database.

Please provide your site’s URL and admin login credentials and I’ll try this as well.


nope i’ve deactivated all of the caching and i’ve also tried deleting, still didn’t work

Hi Eric,

What I’m referring is the internal cache system of your hosting provider. Or have they allowed you to disable them?

What I noticed is, it stay validated for few seconds then suddenly on 3rd reload it became slower which then display that it’s not validated anymore.

Something is resetting it back, or the saved data doesn’t reach the database and only stayed on database cache and got cleared. That’s just my assumption, I recommend contacting your hosting provider and see if you can disable the caching on their site (not the cache plugin).


Hi Rad,

I’ve got a separate account on the same hosting and it validates fine… is there some way of manually forcing this to validate? I’ve tried uninstalling then reinstalling the theme with no success. Is there something in the phpmyadmin / sql that i need to try deleting and reinstalling?

Hello Eric,

Thanks for updating in! I have logged in and revalidated your site. It is now validated. I have simply went on to your license page and re assign the license to the domain you have provided to make sure that it is assign to the correct domain with the correct spelling.

When I revalidated the X theme, it was successful.

Best Regards.

Hi RueNel,

I don’t think you read the above. If you refresh the page, it is showing not successful

I just logged on and i’m still getting:

Any ideas?

i’ve also contacted my host and they said there’s no server side caching that would be impacting.

Hey Eric,

Yeah, I have refreshed the page several time and there it is. It resets and unvalidated.
This could be server related issue. Could you please make sure that you have meet the requirements to run the latest WordPress? It appears that you are running PHP 7.0.33 and the WP 5.0…2 requires 7.2. You can check the rest of the requirements here:

Hope this helps.


i’ve updated as requested but it still validates but after refresh it loses it…

Is the working staging site has the same server and WordPress setup as the non-working production site? Please tell all the differences you can and also give us both site’s cPanel access so maybe we could spot an unusual setup.


it’s using the same host.

Hi admin team + anyone who wants to solve this in the future…

i painstakingly finally found out what was going wrong. I accessed the phpmyadmin and found that in the wpXX_options table, there was a missing value that was causing this. It was the x_product_validation_key. I compared this with another clean install which “worked”.

Here’s the code for anyone in the future:
INSERT INTO wpXX_options (option_id, option_name, option_value, autoload) VALUES (‘150’, ‘x_product_validation_key’, ‘LICENSE KEY’, ‘yes’);

Replace wpXX with your table name
and replace LICENSE KEY with your product key.

Hey Eric,

Glad you have resulted to manually updating the database. The missing value though is only the result of something that prevented the license key from being saved in the database through the license validation page in WP Admin.


Hi Christian, so what could would be the cause of that? :slight_smile:

That something that was also referred to by Rad is still unknown to us.

Finding what that is might take a lot of time comparing your sites though so manually entering the license in the database is the solution for this case. We’ll take this into account for similar cases next time.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.