“Scroll down” button (above Masthead)

Hello team!

Good day!

I just want to check here, usually, whenever I press the scroll down button to reveal the next page, it will fit perfectly, be it in mobile, desktop or laptop or basically in any device…

Suddenly, after I upgraded to the latest version of our x pro, after pressing the scroll-down button, there’s like about an inch of space needed for it to exactly fit to the next page… kindly help on how to fix this. Thanks!

Hi @streetlifebahrain,

Thanks for reaching out.

Please make sure that you updated the Pro to 4.0.7 or X to 8.0.7 and the cornerstone to 5.0.7 , if the issue still persists after updating everything, please give us the following information in a Secure Note and also providing screenshot is a big help.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Good day!

I have already updated to the latest PRO version but still the same. I lost some of the BARS andContainers that we have created. It’s not showing on the website but in Pro Header editor it is showing… Why this is happening? Also, the “Scroll Bottom Anchor” once clicked, the next page no longer fits the screen, unlike before the update, the next page fits perfectly in any device.

Another issue I noticed right after the update is the Customizer, the CSS modifications that I am pasting no longer works.

Please help. Thanks a lot!

Here is the credentials

Hello @streetlifebahrain,

Please have your Pro theme updated again to Pro 4.0.10. This patch release fixes the scroll event issues on your site. By the way, please also address the critical issue happening on your site as well.

See the secure note.

Kindly let us know how it goes.

Good day!

I checked the Site Health and now there is Zero critical improvement needed. But when I checked, still my scroll anchor is not properly working. Also, in my header, the main image is not showing up, only the Bar with the logo and menu is showing up…

Likewise, the CSS codes I am pasting do not seem to work…

I am already on the latest Pro 4.0.10


Hi @streetlifebahrain,

Unfortunately, the mentioned issue is not found on your Home page, the main image is loading properly and the scroll to bottom anchor is also working fine. If you are still getting the same issue, can you please provide any screenshot marked with the issue or any video that help us to recognize the problem?


Hello team,

Good day!

It’s surprising to know that in your test it’s working fine. I have tested this in different mobile phones and desktops but it’s always displaying incorrectly and the second page is not showing up at all (The immediate page after pressing the scroll down button). To show you, please follow the images below:

This is the main page, first thing you will see when you go to the website.

After you click the scrolldown button, this is what you will see…

There are 2 issues here, first… if you can see, it is not fit as it is still showing a part of the first page. Prior to the update, everything was fine. The other issue here is… this is not supposed to be the next page, this is supposed to be the 3RD PAGE. Meaning, in the actual site, the REAL 2ND PAGE is missing.

When I checked in PRO HEADERS, the REAL 2ND page is showing up, but even there, the scroll down button is not working properly, please check the screenshot:

I hope the issues now are all clear. I have cleared cache a lot of times and still, the problem lingers. All of these happened after the update. Also, I have renamed headers but every time I come back to the Pro Headers, the renamed headers go back to their old name. It’s as if it was not saved, but clearly, I always save.

Kindly help fix these issues. Thanks!

All the best,

Hello @streetlifebahrain,

Please edit your slider and make sure that the layout is “Slider” with the size that is in “Fullscreen”.

In your custom header, set your bar height to “auto”. And then I have edited your homepage. The very first section is the one displaying contrary to have mentioned that it is not the first page (section).

Kindly let us know how it goes.

Hello dear,

Good day. Still, nothing happened. The very first image after pressing the Scroll down button is still missing on the main page but is visible in the custom header… please check this image below, maybe you have missed this on the previous email:

This particular image “Filipino to the world” is visible in the custom header but is missing in actual website. Also if you will notice, it is not fit into the screen after pressing the scroll down button.

So, the issue is still there… the first thing that MUST SHOW UP after pressing the scroll down is this image (Filipino to the world). This is container 1 that is part of the Header. This is missing in actual website as mentioned in previous email. There was no problem in slider…

Again the issues are these: Scroll down not fitting properly on the next page and the part of the header image that is missing in actual website but visible in custom header. Thanks!

Best regards

Hi @streetlifebahrain,

I have checked your website on the desktop and it works fine, I have attached a video in the secure note on what exactly I am seeing. Apart from that, I found several JavaScript console issues due to the 3rd party plugins like Multi-Currency, Super PWA, which does not allow the slider to load at the backend to check the settings which may be the reason behind your issues in mobile devices.
I would suggest you please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Hello Team,

Good day. I checked your video, thanks. I don’t know if I made myself clear… the video you have shown is not working properly… because after pressing the scroll down button, the “FILIPINO to the world” image MUST SHOW up. It did not show up on your video as it jumped directly to the main page. In the custom header, The “Filipino to the world” image IS SHOWING UP as shown in my previous screenprints.

Here’s the Wordpress Credentials:

Hey @streetlifebahrain,

We’re sorry for all the confusion. I’ve just tested the Scroll to Bottom anchor in my site and it doesn’t scroll down all the way like in your site so this is a bug.

I’ve posted this in our issue tracker so this will be queued to be fixed by our development team.


Thanks a lot for your response. How about the missing image on the header? Will you also fix that issue? Thanks!

Hi @streetlifebahrain,

Regarding the missing image in the header, it is not showing because the other header overlapping the header displayed on the homepage/front page. When I check your homepage header the priority was set to 10.


When I set the priority to 0, the missing image in the header is now showing on the homepage/front page. To know more about conditions and assignments, please check this doc.

Hope that helps.

Thank you.

Ah great! Saw it now! Thanks!

So the only issue now is that the scroll down once clicked doesn’t fit into any screen…

Another thing, can I put a label on the Scroll Down Button? I want to put “SKIP INTRO” above the button… Thanks!

Best regards

Hey @streetlifebahrain,

Regretfully, there’s no option to change the content of the button. That would require custom development which is outside the scope of our theme support


Oh, okay. I hope next time it can be considered for development. To have the ability to turn on or off scroll down label…


Thank you for your feedback, @streetlifebahrain