Yoast SEO does not recognize text in pages made with X Pro

Hi there

I’m not sure if it is the latest update of Yoast that is causing this.

But since a couple of weeks Yoast is unable to see keywords and read text I’ve made with the X Pro editor.

The strange thing: this only happens one 1 of my 2 websites. On both websites I have latest version of X Pro and latest version of Yoast SEO premium plugin.

Is this a known issue?

How can I resolve this?

Thanks in advance!!

Hi @Woordenaar,

Thanks for reaching out.

I’m not sure what’s going on either, but it’s not a bug since most of them are already fixed in the latest version. This is what I’m seeing in your Yoast panel.

Perhaps you can contact the Yoast author to see what’s going on? Because even if the builder isn’t readable, it shouldn’t trigger that error which isn’t even happening on older builder’s version (which Yoast had issues with).


Hi there

For which page did you get this error? I did not see any error. Problem is that Yoast does not recognize any text on any page for the .info website. On the .shop all is fine :slight_smile: Same version of plugin, same version of X Pro…

Hi @Rad

I just checked on my .info website and I don’t have this error. Please see screenshot of Yoast on homepage:

Snippet loads perfectly. No error there. It is just that no text is being recognized by Yoast…

And I received support from Yoast:

Hi Dries,

Thanks for the email! We looked at this page: https://audiopc.info/wp-admin/post.php?>post=2939&action=edit and we see X Pro Theme is using a pagebuilder. See attached. Yoast is >unable to scan the content of those pagebuilders to give a correct analysis. To resolve the issue we >suggest speaking to the theme developers to add in code to force Yoast to scan that pagebuilder. >This guide explains more: https://kb.yoast.com/kb/can-i-add-data-to-the-page-analysis/.

This is not very helpful and is not correct. I can use same Yoast SEO version and X Pro version on my other websites without any problem. They also use the same page builder but there it has no problem to scan the text.

It is just on my .info site that the problem exists.

I hope you guys could dive into my website and try to find the problem.

I should add that problems started with new Yoast 7.0 release. And only on the .info site. On the .shop it still works perfect as well as on my other sites.

Very strange…

Hey @Woordenaar,

I’d just want to let you know first that this is tricky to catch the cause moreover that this is only happening in one site. I just personally tested Yoast SEO 8.0 in my dummy site and it works. I could not detail each and every analysis Yoast can do though as that would take a lot of time.

Now for your case, doing this ourselves alone would be feasible. This is why, we would need you to do some testing. You can start by making a copy of your page and saving it as a page template and loading it to a test page. Then, remove section’s one by one while checking Yoast analysis each time you make a change. Document the changes when it happens. For example, in my quick test you can see in this screencast, I change the content in Pro and then I save it and in another tab, I monitor Yoast analysis.

It is best though that you start from scratch when dealing with Yoast so you could track progress and issues easily.

Here’s also a bit more detailed test I’ve done shortly after the release of Yoast SEO and Cornerstone compatibility.

Also test non-Cornerstone built pages to see if there’s an issue with Yoast itself.

It’s also possible that the issue is only in Yoast Premium so I’d recommend that you setup another test site and test the free version of Yoast in there.

It is important that you document the result of each of the steps you take to give us an idea of where the issue is coming from so we could replicate also in our test site and submit a report to our development team if indeed there’s a bug.

Please also note that it is possible that something in your server and/or WordPress setup is causing this so you need to test if there’s something in your site that is causing Yoast SEO to malfunction. We could not help with this as we are not Yoast SEO experts. And, also compare the setup of the site that is working and the site that is not.


I experience similar problems with X and Yoast Premium.

Especially on a new page we’ve build the last few weeks:

Here, Yoast has difficulty seeing any content at all.

Did some testing, with stripped down copies of the page and ‘clean’ new pages.

Something I did notice, is that fairly straightforward texts are indexed by Yoast, but more complex items (like Headings), it looks like scripts are not able to run properly.

Another thing I noticed, is that the Reader-view of Safari (which simplifies a page), has big difficulty rendering the above mentioned page. Headings, text boxes, lists, all is becoming one big potpourri.

However, I see the same with a simple test-page, without too much complex elements and styling:
https://www.bentopresentaties.nl/yoast-test-2/ (in which Safari’s Reader-view doesn’t see the H2-subheadings) and Yoast seems to be not indexing the whole page. (However, I should do some more testing to pinpoint where this breaks).

Might this be connected? The complexity of elements on a page and Yoast (and Safari) not being able to ‘see’ things properly?

Well, I found out some things while digging deeper with my page. It seems Yoast breaks down when you use Classic Elements.

On a long page with a Gravity Form added through a Classic Gravity Form element and images using a Lightbox code, Yoast Premium acted up:

When I deleted the form, which was on the end of the page: the error messages disappeared, but statistics looked whack, with too many zero values:

When I also deleted the section containing the Lightbox images (and shortcode), things look normal again:

Might it be possible that (a combination of) Classic Elements aren’t supported with X and Yoast?

Are there perhaps any known workarounds to add Lightbox functionality and add Gravity forms without using Classic Elements?

Hello @bentopres,

Thanks for writing in!

I am really sorry but this thread (though related) has been started by @Woordenaar . Posting on a thread started by a different user creates lot of confusion and slows down the response time. I request you to please create a new thread and someone from support team will assist you accordingly. I would also request you to please take a look look at the support handbook on how we provide support.

Thanks for understanding.

Ah, no problem. I approached this as a community forum kind of way. Appears to be more of a public support ticket thing then. :smile:

No problem at all, thanks for letting me know!

PS Ah, now I see the difference… there IS a forum, however I hadn’t noticed they were separate things. My bad.

Thanks for understanding. :slight_smile:

@bentopres Thanks for your extra input :slight_smile:

So it seems I am not alone with this issue :slight_smile:

@Rad @Prasant @christian_y

I think I found the cause of the problem…

Yoast has checked my website and they say the following:

Hi Dries,

Thank you for your continued patience. We apologize for the trouble you are experiencing with our plugin. We temporarily switched to the default WordPress editor to see how the theme creates the content. Unfortunately, they use shortcodes that do not output content in the backend, even when WordPress core views the text (see image below).

By default, our plugin does not analyze content that is outside of the main content box of a page or post. Some plugin and theme developers add compatibility for our plugins while others have not. Please reach out to the developer and ask them about adding the functionality to their plugin or theme.

Please let us know if we can be of further assistance.

Here’s the image:

The picture shows the output of the X Pro page builder in normal Wordpress editor. Quite obvious that Yoast can’t read that data, as well as Google will not see the keywords etc…

The strange thing is that on my other website these problems are not happening.

So the problem is that X Pro pages are outputting different data on this website than on my other site where all words are correctly read by Yoast.

Am I correct?

And more important: how can I fix this??

Your help is GREATLY appreciated, and you may look at my site for yourself.

I’ve added a secure note in the topic.

Thanks in advance!!


Hey Dries,

I’m sorry to say that Yoast support is partly correct in that the builder outputs what looks like an unreadable jumbled shortcodes. But, in Pro 2.1 and Cornerstone 3.1, an update was released for Yoast SEO to read the data of the Content Builder. That is the important bit there. If you have seen the tests I’ve made shortly after the update and just recently, Yoast SEO indeed reads the data. Please review my previous reply.

There might be something like the known issue in this thread where the analyzer will only scan the contents of the Classic Slider when present in the page. That is a known bug. I have replicated it myself and posted it in our issue tracker.

It looks like @bentopres noticed the same:

Now, in your case, we need to know if there is another element in the page that is causing such an issue too. But, it is hard for us alone to know what that is as I have said in my previous reply.

I’ll answer the rest of your questions below:

Yoast SEO can read the data as per my test I’ve shown previously. But, unlike Yoast SEO which only analyzes content inside the main content box, Google views the front-end of your site and the theme does not output the literal shortcodes in the front-end. With that said, Google can read your site.

We could not fix bugs as support staff. What we can do is to find where the issue is coming from and post it in our issue tracker. This is why, as I have said in my previous reply:, we need you to do some testing yourself as we can’t do it moreover that this involves a third party plugin. Please review my previous reply.

But, as @bentopres has tested and basing on the currently known bug, try eliminating Classic Elements in your page.


@christian_y @Rad

I think I have found what is causing the issue. I want to be sure before I start all the work of testing other things:

The probem only occurs on 2 pages which I have imported via templates.

I made those pages on a development site, I downloaded the template and imported the template to the page on my .info site via X Pro page builder.

So… Only those 2 pages have the problem.

I checked with my posts & other pages. Yoast does work with my posts and also with my other pages. Only those two pages which I imported via template have the problem.

I also checked on my development site and there the page does get read by Yoast.

So I believe there has been a problem with importing the template when creating these 2 pages and that is the cause of the problem.

Could you verify if this is possible, and if there is a way to fix it?

Hi @Woordenaar,

I just tried on my local installation and it works just fine after the import. Perhaps it’s content related to the template? Please provide the imported templates, especially the ones from other sites so the same content is still intact. I’ll try importing it on my local.


Can I send these template files as a secure note? Can’t seem to do this… Could you help?

One more question…

It seems I cannot edit this page anymore since you have checked it. Did you do something wrong.

If I want to edit the page I get this error now:

Page is made with content builder, not outside content builder…

Did you alter something?

Your help is very welcome…

Hi @Woordenaar,

I didn’t do anything since we’re only testing the SEO. It’s been like that as your previous screenshot.

The the text appears upon load if it’s edited outside the builder which the warning appears if you try switching to Pro tab.

You can upload your templates in a file hosting site like dropbox and provide the download URL in a secure note.


Hi there

Problem is solved! :slight_smile:

It was quite an easy fix actually. :wink:

When changing editor from Pro to standard Wordpress and back to Pro again Yoast is now able to read all text.

Thanks for all your efforts. @Rad @Prasant @christian_y

And I hope this fix for Yoast not reading X Pro content can also be helpfull for others with similar problems.

Like @bentopres :slight_smile:

You’re welcome, @Woordenaar. Your findings are helpful.