WPBakery Library Templates Don't Work

We’re having an issue with the WPBakery Templates you can download via the page builder. When you click on “Templates”, then select “Template Library” and either download one or click one already downloaded, they do not display properly. The content is there, but it’s not laid out the same as the preview.

I figured it was a CSS thing, so i activated the parent theme to test and it was still broken. But as soon as i simply activated the Twenty Twenty theme, all the downloaded library templates worked fine! So it’s something between the X theme and WPBakery.

Is there anything we can do to work on getting this figured out? We really like the idea of this packaged purchase (THEMECO ‘X’ and WPBakery) because of things like this. So being able to utilize pre-built templated pieces is key for us.

Hello Rob,

Thanks for writing in! For bundled plugin in the theme, you can use all the plugin functions and features except the template library. Please be advised that WPBakery Template Library is only accessible if you have purchased a separate plugin license and activated the plugin.

This policy has been imposed by the creators of the plugin as an exclusive to registered plugin users. For more details about this bundled plugin, kindly check this out: https://theme.co/docs/wp-bakery-page-builder

Best Regards.

Thank you for the reply. We actually have a premium license and can access and download library templates (see screenshot). The thing is, they don’t display properly because of something between theme X and the plugin.

Some further investigation shows that a lot of settings are missing when using the THEMECO X theme with the WPBakery plugin. Here are two screenshots. One with the THEMECO X theme active and the other with the basic Twenty Twenty theme active. You can see with the basic theme active, when you click on the edit icon, in the popup, there are more design options available.

Options with THEMECO X Theme active:

Options with Basic Theme active:

Hello Rob,

Kindly go to WPBakery Page Builder > General Settings and make sure that “Legacy X Integration” is disabled. If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Disabling “Legacy X Integration” fixed it! Crazy it was that easy. OK, we’re good to go now!

Thank you so much Ruenel

You are most welcome Rob!

Hello again Ruenel,

So there is actually a bit of a hiccup with that setting. Here is a screenshot of the home page and how it is supposed to display. This is with “Legacy X Integration” ENABLED

And This is with “Legacy X Integration” DISABLED

You can see how all the sudden there are those red buttons everywhere, the formatting is gone, etc.

Hi Rob,

To better help you with your concerns, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.