Woocommerce Can't Add to cart/ Remove page not refreshing/Integrity Stack

Hi,

Since the previous updates, it seems that something weird is happening. For some strange reason. when I add items to the cart they do not actually appear on the card until I refresh the page. This is happening on all pages. For instance, where I have an add to cart on a page where Cornerstone is used it takes you to the single product page and when you add to the cart sometimes more than a single item is being added or in some cases no item at all. When I visit my cart page and I tick the X to remove items from the cart they appear to remain until I refresh the page. Items do not seem to appear by default in the shopping cart or get removed unless I refresh the page.

Yes, I have cleared all caches and deactivated plugins but can’t figure out why this is happening suddenly. I can be on a specific page where I added let’s say 10 items that don’t seem to appear in the cart when I navigate to the next page until I refresh.

Hello @fantasy_5,

Thanks for writing in! You are using SiteGround and Cloudflare. Have you cleared the site caches already? Since you are using SiteGround, please clear your site cache or at least disable the Supercacher in your hosting panel. The SuperCacher is developed by SiteGround exclusively for their customers. It increases the number of hits a site can handle and boosts the website loading speed. The SuperCacher includes 4 different caching options for maximum optimization of your websites. You can access the tool by clicking on the SuperCacher icon in your cPanel.

For more information about this, please check it out here: https://www.siteground.com/tutorials/supercacher/supercacher_intro.htm

And also I found out that you are using CloudFlare. Right after your updates, please log in to your CloudFlare account and purge your site cache. You also need to regenerate the minified CSS and JS files in CloudFlare.

Hope this helps.

Hi, Ruenel

I tried your suggestions and it seems that I am having the same issue. Can you please kindly check it out for me. I need help solving this problem.

Hi @fantasy_5,

Sorry but I can’t replicate the issue on my end, I can add products and remove products on the cart part on your site without an issue. Please provide us a step-by-step guide on how we can replicate the issue, and if possible, please clear and deactivate all caching plugin/feature you have on the site while we investigate the issue.

Another thing, please make sure the product that you’re adding to your cart is not out of stock because that is not really going to be added on the cart.

Thanks,

Hi, Friech

Yes, I can also add items to the cart. However, they do not seem to appear in the cart without a page refresh and it’s a similar issue when trying to remove items from the cart. When I add items the cart count sometimes remains at zero or the previous cart total unless I refresh the page. How can I send a video capture here? I tried awesome screenshot, but it downloads as a webmd file that 'I have trouble creating a link for in google drive.

Hi @fantasy_5,

Thanks for the clarification, yes I can replicate the Navbar Cart not updating (AJAX) on my end. This issue has been added to our issue tracker so that our developers can investigate this further. We cannot make any promises relating to a fix at this stage. I will add a note to the tracker referencing your report though so our dev team can see there are multiple reports of the issue.

I can not replicate the issue about removing an item on the cart page though. This could be a caching-related or a plugin conflict-related one, please do a Testing for Plugin Conflict and clear all your caching plugins.

Thanks,

Hi

I did testing for plug-in conflict and cleared my caches more than once. This does not resolve the issue.

Hi @fantasy_5,

My colleague has already reported this to our issue tracker for further investigation by our development team.

Thanks

I hope it can be resolved soon. Thanks.

Hi @fantasy_5,

It has been already reported for further investigation, and hopefully, it will be fixed in succeeding releases.

Thanks

Hi, Tristup

I am using Uber Menu. Do you think the ajax issue I’m having can possibly lies within the plugin?

Hey @fantasy_5,

Yes the issue could be within the plugin, we’ve already reported the issue for further investigation.

Thanks!

Hi, Nabeel

Should I reach out to the plugin developer? I’m ready to launch my website and customers can’t properly place an order if the ajax is broken and items are not appearing in the cart.

Hello @fantasy_5,

We’ve already reported the issue for further investigation There’s no update yet from the plugin author.

Thanks for understanding