Version 3.2.3 to 4.3.3 or 5.0.8 . headers are gone and not displayed frontend anymore

Follow up on: Version 3.2.3 to 4.3.3. headers are gone and not displayed frontend anymore

Checked conflicts and disabled all plugins and only running PRO child theme, even tested to switch to PRO theme to exclude any potential issues in the child theme code.

Still the headers conditions is not working, all specific page level headers are overridden by the main apply everywhere header. Even if using correct conditions and -1 or 0 and 2 on the main header.

The issue is in the builder, not in a plugin conflict.

Hi Mike,

Thanks for reaching out.
Can you please re-share the details of your Staging site where you are having this issue, credentials shared in the reference thread is not working anymore.


Sure, shared in a secure note.

Hi Mike,

Thank you for the credentials, but there are a lot of pages and headers on your site, please provide us example page and header.

In the meantime, please CLEAR (includes transient cache) and DEACTIVATE all your caching plugin/feature your site might have.


You can pick any header and example is given in the previous ticket. Yes a lot of headers as it took you several of years to improve the feature of allowing us to combine header and inherit that one etc. So this is how we had to build it due the builder.

If you read we have already tried clearing all cache and deactivated all plugins except pro theme even using pro parent theme and not child theme. Issue is still present, I’ve done my things the issue is now on your end to find the bug. We have an old version of the plugin just because of this major issue for us.

Hi Mike,

I have checked your website and created a Test page and found the Header is working fine. I have also added a specific Header to that page and that works too. I would suggest you check once if that issue is still exists or not, if that exists please provide the specific page and the header with which you are having the issue.


If you go into the header builder you would see that non of the headers are applied due to the new conditions. On every page we have a unique header due to previous limitations in the builder we had to build like this to archive what we wanted design wise.

All pages show the main header which has condition “entire site”. I know your conditions and I’ve tested this 100 times, the bug is in PRO theme and the migration once you introduced this. Something must have gone wrong.

I’ve linked in secure note where you see the page and what header is suppose to be displayed there.

The migration once you introduced conditions you converted all to specific page is and then the page with priority -1. Still they are not displayed.

I suspected there is an issue with the previously created header and there is a bug there in the header builder. But I duplicated a header without success also changed the header for entire site which should be able to override as this is applied once something else isn’t more specific and with a higher priority. But didn’t work to change form entire site to singular even if priority on it is 20 and page specific ones is -1.

What I tried then was to disable the main one for entire site. Then I see no header at all. Broken default theme header. So it’s obviously something broken in the conditions for specific pages. Please look into it, what is wrong?

I saw your test page kindly duplicate a new header which isn’t main which you used. Use a page specific as the one in the secure note to prove I’m doing something wrong. As all I can see is I’ve tried everything and there must be a bug in the builder.

Hi Mike,

Sorry, but the Temporary login link you provided above is not working anymore. We can’t list this as a bug if we cant replicate the issue.

In the meantime, please do the following,

  • Try creating a new header and assign that to the entire site.
  • Clean all types of cache including transient cache, you can use something like WP-Optimize – Cache, Clean, Compress.


The temporary login was just for 1 week you took 7-14 days to revert on the ticket since the login was generated. I’ve crated a new one for 4 weeks please check again.

Hi Mike,

I have duplicated a Header and assigned it to the specific page and it works, but when I renamed the Header is overwriting the settings with an empty object. I have already reported this issue to our development team for further investigation.

As a temporary solution, I would suggest you not to rename the duplicate Header.


So you tell me the migration failed as my thought? The solution is to duplicate all headers? We can not site and duplicate all of them. Pro builder is too slow to handle that amount in general + the workload this cause. I’m looking for a root cause problem to be fixed instead of duplicating all headers.

Can you kindly look into the problem why the original assigned header isn’t displaying? As said we can not do 200 new duplicated headers. The job doing this due to a bug in the plugin is not OK as a solution, the root problem of why my headers no longer works is what needs to be fixed. The interface in header builder is neither built to handle bulk. Meaning the search and find and see all is a nightmare.

So the workaround is not suitable.
What needs to be done:

  1. Find root cause in the condition module.
  2. Focus on why original headers is no longer working in the condition specific page.
  3. Report back.

Hi Mike,

Really sorry if that creates any confusion. I tested your site and found that renaming the Duplicate header is creating that issue, so my solution was if you are duplicating any Header then please don’t rename it.
I have already reported this issue to our Issue Tracker for further investigation by our development team.


Thanks Tristup.

You explain the problem if I duplicate a header. Reported on the issue tracker for further investigation by the dev team.

But the issue which occur on the site right now where no page specific headers display isn’t investigated and reported yet? Why is the headers which have conditions page specific and correct condition priority not displaying? Did you look into this issue? Which is the issue we are facing.

Hi Mike,
I have already checked your website and am able to replicate the issue at your end. I have reported all the cases to our issue tracker for further investigation.

Okay, thanks. Then how long do we have to wait until we have an update on this for the dev team in the investigation. Looking forward to a solution and patch fix of course as we are on an old version on production but with this issue we can not update of cause as you might understand.

Hi Mike,

I have already reported this issue to our Issue Tracker for further investigation, but unfortunately, there is no ETA on this till now.


Can you have the development team update on this ticket once they have looked into it? Will the ticket be open until you have an update?

Hello Mike,

Our developers are already looking into the issue. And by the way, tickets will be closed after 10 days. You can post a new thread for a follow-up after 10 days or just monitor our changelog for the issue if it has been fixed already.

Best Regards.

Okay do you have any updates it’s a pretty big bug and prioritizing new feature over big bugs as it seems like right now with the slider element.

Hey Mike,

Thanks for the updates. Our developers are already working on this. We just don’t have any ETA on this. We will add a note to the tracker referencing your report though so our dev team can see there are multiple reports of the issue.

Please bear with us.