Unresponsive nav after scrollTo on mobile


First of all: Happy New Year! Hope you guys had great holidays :slight_smile:

I feel like this thread has been forgotten:

I’ve just updated to PRO 6.4.7 (latest) but the issue still persists. Can somone please take a look again?

My clients website isn’t working on mobile for almost two months because of this.

Any help is appreciated!

Hello and happy new year.

All touch events on your site are getting routed to the HTML element on iOS. I suspect probably from z-index issues on the body and html element in my tests. Android handled this better without issue. This would probably explain the scrolling issue you initially had too.

I would spin up a staging site for us if you want us to take a deeper look, so we can test this with complianz deactivated as well as hummingbird.

Have a great weekend.



Hey Charlie,

Yeah that would be great!

I deactivated all 3rd party plugins for debugging but wasn’t able to figure out the problem.

You can set up a staging site if you want :slight_smile:


I noticed something strange on desktop (Safari 17.2.1) as well.

As soon as i click on one of the nav links, the page jumps all the way to the top before scrolling down to the corresponding section afterwards.

Apologies for the late response. I was hoping someone else would come to us with this issue so I could find the similarities that cause the issue. I couldn’t tell you right now what’s going on though. The window + document scroll fix i mentioned in your other thread probably just gets around the fact your page is jumping to the top scroll pixel. I still imagine it’s something with the body tag. I’ll have to time to go through your site on Pro 6.3 - 6.4 later this week. After the release of 6.4.9. Have a great day.

1 Like

Commenting out this fixed the scrolling. Let me know if you see the same thing happen when you try this. Have a great day

Yes, commenting this out fixed it on mobile – thanks! Weird thing is, this used to work a few updates back.

On desktop however, it seems to have some kind of offset when scrolling down. Clicking the first and second menu item wont do anything (the CTA button as well). Clicking the third one, takes me to the second section now. The fourth takes me to the third. The calculation of the scroll position appears to be off by one section.

Tried renaming the sections ID’s but this also didn’t do the trick.


tried narrowing down the issue, but still no luck. This still is an issue:

Hey @charlie,
Any updates on this?

Turn of the “Sticky” in “sidebar old”, that’s the sidebar that is positioned at the right side. Alternatively set the “Z Index Stack” to true. Since you styling with CSS I would suggest to turn of the sticky setting. It’s registering as a fixed top so it’s placing all anchors below it’s height. Sorry I didn’t catch this before, probably why some of the jumping you were having before was happening too. Have a great day.

1 Like

Oh, this explaines the offset it had as well. It’s finally working now!

Thank you!

1 Like

Hi @sparko,

Glad to know it is working now.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.