Trouble with one page nav

See: https://andrewkirsch.info/speaking/

The contact section is on this page, so I wanted a one page scroll for this page only. I have set it up as usual. I made a header only for this page, and used the one page menu, and selected one page menu in the page editor.

Yet on the mobile view, its highlighting both:

Hello @logoglo,

Thanks for writing in! You will need to explicitly assign a One Page Navigation menu in your page. Please check out this documentation first:

If nothing is helping, we would love to check your page settings if you wouldn’t mind sharing your WP details. You can create a secure note in your next reply with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
– Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

image

Best Regards.

Thanks, yeah, as I said, I made sure it was one page nav:

I added login info in the secure note.

Thanks for your help.

Hello @logoglo,

Please edit your “Menu mob” and use relative URL for the menu item link HREF.

Kindly let us know how it goes.

Hi, thanks, but that menu is used for all other pages, and the mobile menú speaking is used for the page I need one page nav on

Hello @logoglo,

The one page navigation menu should be a different set of menu items. You will need to create two sets of menu. One menu will be used site wide and this will contain absolute URL for the menu item HREF. The 2nd menu will be used exclusively for the one page navigation and this time in this menu, the menu item HREF will be using relative URLS like #contact.

Hope this makes sense.

That is what have done. There are 3 menus. 2 used site wide for desktop and mobile. And one for the one page scroller mobile for the speaking page…and that is using #top, #contact etc…

Hey @logoglo,

I see you have a header for your “Speaking” page. However, it does not apply to your page because of conflicting conditions. I removed the “Page Specific is not Speaking” condition in your main header for your Entire Site and changed its Priority to 1 (higher number means lower priority).

Your menus now are correctly highlighted.

image

Awesome! thank you so much for your help.

Hey @logoglo,

You’re welcome! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.