The preview could not load due to misconfigured URLs (different domain per language)


We have a multi language site with unique domains per language through WPML.

We’ve been using Pro for years with unique domains per language. After updating to the latest version of Wordpress, WPML and the Pro theme we are not able to update any other languages except for the the main language through the preview mode.

Some years back this worked like a charm using the flag switcher in the bottom right corner. Then after an update we manually had to change the domain url to the top domain for the language to be able to edit in preview mode. And now we are not able to update in preview mode at all.

Any ideas here?

1 Like

Hello @thomaslangvik,

Thanks for writing to us.

It seems that there might be an issue of plugin conflict. I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme
  5. Css/Js Customization
  6. Increasing Php Memory Limit
  7. Disabling Cache
  8. Disabling Cdn
  9. Permalinks
  10. Version Compatibility

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • FTP Details

You can find the Secure Note button at the bottom of your posts


Thanks for your reply. I don’t think it’s related to anything on that list except for maybe a WPML plugin conflict. The way our setup works is as mentioned above, we have different domains based on language. mycompany.xx for the default language and mycompany.yy for the secondary language. So the way it looks in WP for the main language is like this:

site_url: mycompany.xx
home_url: mycompany.xx

But for the secondary language it looks like this:

site_url: mycompany.yy
home_url: mycompany.xx

And there you get the conflict with the preview. The difference between site_url and the home_url. And as said, this has always worked in the past but after the update we are stuck.

Our problem is very much related to this issues, WPML cornerstone bug.

So it looks like it happened again after your lates update. Conflict with WPML. We could of course do a downgrade to earlier version of WPML but this would not be a sustainable solution going forward.

For security reasons we are not able to grant you access to our setup. Hope this can be sorted without that. :slight_smile:

Looking into what’s been done to the version 4.4.9-b.1 of WPML they have “Fixed Language Switcher settings for Elementor themes.”. Maybe this could be related.


I’ve tried to downgrade the WPML even 4 versions back with no success. Guessing that’s not the problem.

Using inspect console I get these errors in edit mode for pages where I only have the secondary language.

For pages where I do have both default language and a secondary language and want to edit the secondary language the id for the Pro content immediately redirects to the default language and with the error message mentioned in the heading.


And the settings in WP is similar to this (when url is set to the secondary domain). As it always has been.


Thanks for quick help and solution if possible.

I just found out that I am able to update the secondary language in preview mode if I disable the WPML plugin. So I guess there is a conflict between the Pro theme and WPML. No clue on whose end though. :slight_smile:

Hi Thomas,

Thanks for reaching out.

Themeco and WPML are talking about the issue between the two products and they will have a solution soon. In your case, we need to check your WP dashboard so that we can give you a clue on what’s going on. To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hi @marc_a and thanks for you reply.

Great to see that you are working on it. As mentioned above I am not able to grant you access due to security reasons but I hope the future solution will solve our case.


No problem.
If you need anything else we can help you with, don’t hesitate to open another thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.