Slider Revolution 6.0.6: Sliders Absent


I have just noticed that on all of my site pages, with the exception of the home page, my sliders created with slider revolution are absent.

I am running WordPress 5.2.2 X – Child Theme theme. (X version 6.5.5).

All my plugins are up to date. Slider revolution is version 6.0.6. The majority of my site pages use slider revolution, sliders below the masthead, and I had previously activated the sliders through the Page Settings \ Slider Settings : Below Masthead - selecting the relevant slider for the relevant page. Said setting is still activated.

I don’t know when the sliders stopped appearing as I didn’t notice the discrepancy until today. The Slider Revolution slider on my homepage is still working though…

I tried trouble shooting the issue using your guide Troubleshooting Plugin Conflict, Possible Javascript Conflict, jQuery Library Load Problem made no difference. I also deactivated the Child Theme etc etc.

Any assistance you can provide would be most welcome. The home page revolution slider works perfectly.

The nearest I could get to resolving the issue was by rolling back Slider Revolution to version Sliders would not appear on the front end pages - however at least I got a placeholder and the following error message: “Revolution Slider Error: The param Slider Width should not be empty.” As the site is live, I couldn’t leave it with an error message so the Slider Revolution is up to date at version 6.0.6.

Let me know what you require in order to see the site which I have created for a client.

Hi @sewotherspoon,

Slider Revolution now needs that you load its libraries to the pages where a slider has been added via a function in the PHP page template which is the case in our themes if you use the Slider Above and Below Masthead option.

Please follow the solution in this thread:

Hope this helps.

Great thanks, the above worked. Much appreciated. All resolved.

You’re welcome!
We’re glad @Lely were able to help you out.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.