Portfolio filters not functioning, overlapping

Hi there. I’ve recently run a theme and cornerstone update, and am experiencing some issues with my portfolio filters. On the initial portfolio page (http://www.qjconstructions.com.au/project-gallery/) you can see it loads well, but when selecting one of the filters, the images overlap and don’t layout properly. None of the filters will work from that point. Any suggestions on what I might be able to do to fix this? Thanks.

1 Like

Hello @alikau,

Thanks for writing to us.

I checked your site it seems that there is a JS console error, it might be due to plugin conflict or JS/CSS customization. I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme
  5. Css/Js Customization
  6. Increasing Php Memory Limit
  7. Disabling Cache
  8. Disabling Cdn
  9. Permalinks
  10. Version Compatibility

If none of those work, It would be best if you could copy your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • FTP Details

You can find the Secure Note button at the bottom of your posts


I am having the same issue.

@alikau I’m having the same problem as you here: https://karmaela.com/portfolio/
Only noticed it a few days ago. Did you come up with a solution at all?

Hello Guys,

Thanks for writing to us.

I would suggest please follow the steps that are mentioned in the above posts, in case if it doesn’t work for you I would suggest you please open a separate thread with your details so that we can check it at our end.


I am also having the same issue. After updating from 9.0.8 to 9.1.4 (also updating to compatible Cornerstone), the portfolio layout looks fine until scrolling down or tapping a filter button. Images slide on top of each other and none of the filters work without reloading the page.

I see also this report where their site behavior when I visit is exactly like what’s happening at my site and @alikau and @karmaela sites above.

X theme Portfolio category buttons - new major issue has popped up

Given this post from 9 days ago that there is a known issue with portfolio display, is there an update on when a fix might be forthcoming? and/or can these reports be added to the dev team’s awareness of the issue? I don’t want to go through all the various testing steps if there’s nothing I can do until a fix is released.

Further info which might be helpful:
One test I have done: I have switched from my child theme to X to see if the issue might lie in my child theme, but the error is still present with X Theme activated. (I have switched back to my child theme and the error persists.) The page appears to load correctly but as soon as any interaction with it happens, images slide on top of each other and the filter buttons no longer work.

Also, there’s this report from Nov 1 (right after 9.1.0 was released) where the user reports their portfolio isn’t loading, then posted that it was working again, but if you go to their site, it’s all good unless you click the + and try to filter. Then behavior is exactly like at my site and those above - the user may not realize there’s still an issue but I mention it because the behavior is the same.

Portfolio pages not loading images

I am also experiencing the same error. The console then logs several errors per second. All of them concern jQuery.min.js:2620 (TypeError).
Does anyone have a solution yet?
Disabling PlugIns, Cache off, ChildTheme off etc all have done nothing.

Hi @cjk2,

This is a known issue with the latest version of the theme and has already been reported to our issue tracker for further investigation by the development team.


Is there already a date when the update will be available?

Hi @cjk2,

Regretfully, there no ETA for next update.


Hi there, we’re having exactly this same issue on our website. We updated to the latest version of the theme (9.1.4) and the issue is still present. Hope it gets solved in the next update.



Hi José,

I have added your one to the list for investigation.


Hi everyone,

I apologize this problem has persisted. We don’t have an imminent point release coming, so there are some options.

  1. Download the previous version of X or Pro from your dashboard and install it. Unfortunately this will remove new features like the Slider elements.
  2. Or (preferable) Add this line of code under Global JS in Cornerstone. (Click the JS button, then switch to the Global tab)
if (window.jQuery.xIsotope) window.jQuery.xIsotope.settings.animationEngine = 'css'

That will prevent the jQuery errors and restore masonry functionality. When the next release comes out, you can remove this code, but it won’t be harmful to leave it in place.

Option 2 works a treat, thank you!

Hi Pyanfar,

Glad that we are able to help you.


1 Like

Option 2 also worked great for us! Portefolios up and running! Thank you!

Hi @qualalbatroz,

Glad that it helps.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.