Page not found error appearing dispite backend page existing as live

Hey team,

I created a page:

It is showing a 404 error. However, it is a live page.

I am not sure how to troubleshoot that kind of mistake. Any advice?


Thanks for reaching out.

Please make sure you publish the page properly, if it is not helping then please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

As far as I see everything is published correctly. This is happening with all events.


Thanks for checking


Thank you for the credentials, but can you let us know what is the title of the page on the back end?

I can’t find the page in the back-end named “introduction to Buddhist meditation”

Are you sure this is an existing URL? where did you get this URL from? Please clarify.


Sure @friech, it is an event. You can see it on the backend. I will link to the event edit page. That appears. The preview appears. Just not the live page.

I tried to create a post to redirect the event to. The post also failed.

Also, as an FYI, I set up a temporary 301 redirect for the original link so I don’t loose event signups. You can disregard the appearance of the page on the site that the link leads to, it is not the issue page.

Ok. So, I am not sure why the problem arises. But, this is what I can tell you.

The issue arises in WP 5.5. My posts and custom post types do not appear on the site. What I mean is if I type the url or view the post, it will not appear. However, if I use a plugin like posts on pages, I can get the content called in to appear. Very weird!

I use custom permalinks. In 5.5 I can revert to plain links and my posts and events appear. If I stick with custom, numeric, post name, etc, they do not work.

I have reverted to 5.4.2 so that my site can function properly.

I am not sure if this is a bug within X and 5.5.


There is an on going fatal error in your homepage. You may need to resolve this first. A certain PHP code or a plugin may have causing this fatal error. Kindly check out this article to troubleshoot:

Hope this helps.

Thanks @ruenel

After I identified the problem with 5.5 my hosting company attempted a downgrade. During the downgrade some files were corrupted and now we have that fatal error. They are working to resolve that issue.

I believe my above notes provide y’all some good information for your own compatability testing with 5.5

Thanks for letting me know about the issue.



Please inform us as soon as the fatal error is resolved so that we can continue to troubleshoot your site. We have already tested our local testing servers and we cannot replicate it from our end. We will continue to check from our end.


It is resolved. But, I have the site running on 5.4.2

The error that I get with 5.5 creates excessive interruptions to my sites usability. I will have to create a dummy site for you to trouble shoot this issue if I am the only one who experiences a failure for posts to display with custom permalinks

Hello @KMCHTX,

We have tested WordPress 5.5 and Pro 3.2.3 and we could not replicate any errors. It might comes down with your server configurations. Please do check the recommendations with this documentation:

See the secure note as well.

Thanks @ruenel

I set up a clone of our site and made sure that it meets all the requirements on your version compatibility. The error persists.

Hello @KMCHTX,

Please provide us the credentials for your staging site so that we can log in and check your settings.

Thank you in advance.

No problem

Hello @KMCHTX,

If you go to Settings > Permalinks, there is a message:

If your .htaccess file was writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

You will need to log in to your FTP and browse to the WP installation folder and edit your .htaccess file. You will need to insert this in your htaccess.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

We would love to know if this will work for you.

The htaccess already had mod rewrite in it. The BPS plugin set that up.


Can you also provide us FTP access for your staging area and put it in the Secure Note so that we could really help you with your concern.

Thank you.

Sure thing.


You forgot to add your FTP password, please update your secure note.

Thank you.