License Already Registered / Revoke Not Working

Hi there,

I recently built a site on a temp domain with X Theme, revoked the license, transferred the site to the client’s domain, and then tried to revalidate, but it won’t work. I also looked in my ThemeCo account but it’s not showing up there. When I try to add the license key to my Themeco account, it says it’s already been registered (but it’s not in there). Any ideas? I’ve cleared my cache already and this hasn’t worked either. Now the license isn’t validated on my temp website or in the client’s website. Help!

Hello Lisi,

Thanks for writing to us.

It might be the issue of any plugin conflict, cache issue, or any browser extension that is stoping to validate the site. I would suggest you troubleshoot with our troubleshooting guide.

In case if you haven’t seen our doc for license validation please have a look at it.

If it doesn’t help you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.