How can I edit translated pages in x-pro with wpml? Settings in Backend? String settings?

I translated the German pages to English using WPML Translation Management.

The footer on the translated English pages is not displayed correctly: Menu is partially not taken or displayed and there is a mixture of German and English takes place on the translated pages.

The translated pages (EN) are displayed in the frontend in german and not in english (when i switch from german to english).
if i want to edit the translated english pages in the frontend with Pro, it doesn’t work. sometimes also the layout in english is not displayed correctly.

I have also tried according to these instructions: but under settings there is no “use the translation editor” button as shown in the video.

what do i have to set? How do I have to set the wpml with x-pro for translating the pages?

Hello Janine,

Thanks for writing to us.

It might be the issue of WPML settings or cache issues. Please make sure you have the latest version of the theme, plugin, and WordPress as per our version compatibility page. In case if you have not seen our doc about WPML settings please have a look at our doc.

I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

If none of those work, please send your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.