Header stuck and screen stuck

Hello,

The header on our website is still getting stuck. I posted about this in the past and you said it wasn’t happening on your screen. However, it is still happening, so we would love to find ways to fix it.

Your can see in this video the header gets stuck on the hero image. Additionally, sometimes the whole page gets stuck and even when scrolling, you can’t move on the page.

Hello Ashley,

Thanks for writing in! I have investigated the issue and I was able to replicate it. It only happens in the Safari browser. Using Chrome or Firefox seems perfect. This could be a Safari Browsing caching issue. I also found out that you are using Cloudflare. Please purge your site cache and then turn ON the Development Mode before testing the site in Safari’s private browsing mode again.

Kindly let us know how it goes.

I cleared the cache as shown below. How do I turn on development mode?

Hi Ashely,

You need to turn on the Development Mode in the Cloudfare dashboard, and then clear all types of cache including the Style Cache from Cornerstone > Settings > System > Clear Style Cache and then check in the incognito/private mode of the browser.

Hope it helps.
Thanks

Hi, where is the cloud fare dashboard? Forgive me, I did not know we used cloud fare and I do not know what that is.

I pressed clear style cache in the place you displayed above. Thank you for that.

Will this prevent only my screen from the header getting stuck… I want to make sure this doesn’t happen to other users on our site.

Hi Ashely,

You need to login into your Cloudfare account in https://www.cloudflare.com and enable the Development Mode for the specific website.

Hope it helps.
Thanks

Thank you. I need to find out who has the login for this and then I will try that.

Just to confirm… how can I prevent this from happening on everyone’s screen? Will doing this only help the display on my screen?

Hello Ashley,

Based on my test, it is only happening when using a Safari browser. If most users will be using Chrome, Firefox, or MS Edge. Clearing the Cloudflare site cache could help.

Cheers.

Okay, thank you. Unfortunately we don’t know whose email is associated with our account so I am asking around the previous people who worked on this site to try and figure it out.

If there is anything else we can do to solve this problem, please let me know. It would be a big issue if this continued. I imagine many people would leave our site if the problem persists.

Thank you again for your help.