Global Blocks : 404 causing "The preview could not load due to the iframe response being incomplete"

Since upgrade to new release, we get “The preview could not load due to the iframe response being incomplete. This is most often related to a plugin conflict, or customizations introducing a PHP error.” errors when trying to edit global blocks.
The Developer Console shows an HTTP 404 error, that may cause the issue. See screenshot.
Can you help?
Best Regards,

Hi @calinda,

Thanks for letting us know about this. Would it be possible to login to check your site? You can add login credentials in a secure note.

Added in a secure note above

Hello @calinda

Thanks for sharing the credentials, I went ahead and checked your site dashboard it seems that you have not given administrator level privilege to this user account. I would suggest you provide admin-level permissions to this user account so that we can investigate your settings.


We have the same problem as of last night. We are using an alternative way to stream our Christmas services for now.

Hi @scheramy,

There could be a plugin or custom code that affect the preview of your website.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

I tried that troubleshooting to no avail.

Hi @scheramy,

Thanks for sharing your credentials.

There’s a compatibility issue with the X theme and Cornerstone plugin because your X theme currently installed is 7.2.3 and you have the latest version of Cornerstone 5.0.10. I went ahead and delete the cornerstone plugin to avoid any error when upgrading X theme to the latest version. After upgrading the X theme to the latest version, I also install the latest version of the cornerstone plugin again and you can now edit any of your pages.

Hope that helps.

Thank you.

Thanks so much!!

Glad that we could be of help.


One other issue has remained. The embed code from our streaming service now doesn’t work on most phones or laptops. The embed code is:

<iframe width="640" height="360" src="" frameborder="0" allow="autoplay" allowfullscreen webkitallowfullscreen mozallowfullscreen oallowfullscreen msallowfullscreen > </iframe>

Hello @scheramy,

Are you using the classic embedded video element? There is a known issue with the classic element. In the meantime, please have it replaced with the video element instead. To learn more about this new video element, kindly check out this documentation:

Best Regards.

That worked. Thanks and Merry Christmas!!

Hi @scheramy,

Glad that we are able to help you. And Merry Christmas to you too.


Hi @prakash_s, I upgraded the account permissions. Please let me know when you are done so that we can remove it.

Hello @calinda,

Thanks for updating the credentials. I went ahead and check your dashboard. It seems that there is some plugin conflict with Polylang plugin and there is also issue in your child theme. I activate the parent theme and deactivated the Polylang plugin then your global block works fine. I would suggest you deactivate the child theme and Polylang plugin then check it.

Please note that we don’t provide the customized child theme and any third-party plugin support. It is out of the support scope.

Thanks for understanding

Thank you for investigating. That’s interesting, but puzzling.
I tried emptying both the custom functions.php and style.css code in the child theme, with no result. Only activating the parent theme AND disabling Polylang does work.
Too bad you won’t support this… What multilanguage plugin do you support?

Hi @calinda,

The multi language we supported is WPML. For more information about the WPML plugin please check our docs.

You can also check the other plugins we supported in our Version Compatibility.

Hope that helps.

Thank you.

I’m having the same problem, but appear to have the latest versions of everything running. How do I cancel the update please as I can’t amend any of the pages on my website at the moment? Thanks in advance! I’m happy to share credentials in a secure note, but I’m not sure what credentials you need to check, so please advise.

Hi @Kerry_Cox,

I would request you create a new thread to share the credentials in the secure note to investigate your issue further.