Events Calendar Pro not displaying after theme update

I just updated Pro to 5.0.6 and now the month view of the Events Calendar Pro does not work. The page layout has changed and there’s weird copy on the page. I have tried deactivating the plugin and reactivating it, but nothing worked.

How can I get support for this issue?

Hello @NLeVasseur,

Thanks for writing in!

You are experiencing this issue because you are not using the default Events template. Please go to Events > Display > Basic Template Settings and set the “Events template” to use the default Events template.

Kindly let us know how it goes.

Hi Ruenel,
I did as you suggested, and it looks better but is not displaying as before. Attached are two images from our staging area so you can see the admin settings and what it should look like on the front end.

Thanks so much for your help, Ruenel. I sincerely appreciate it.

Thanks so much for your help, Ruenel. I really appreciate it.

Hi @NLeVasseur,

You can check this thread as an alternative way to display your The event Calendar on the page properly.

Hope that helps and let us know how it goes.

Hi Marc,
I walked through the process above and ran into a lot of problems working with creating a layout. There is no element that I can find under Dynamic Content called The Content. Here is what it looks like now. This page is not in the menu. Scroll down the page. It looks really bad.

I am back to the public events calendar page found here: and am trying to fix it with CSS.

update: I got the individual events to display nicely. See this event:

I am stumped as to why I cannot add some padding to the month view found here:

Here’s what I am using for CSS:

Hey @NLeVasseur,

I’d let you know first that The Content element is available in your site. You’ll just have to “search” it in the Elements.


Your New Events Calendar page looks bad because you used the Widget Element instead of The Content and the events calendar shortcode within the content as described in the other thread.


Regarding your Events page, it is Tribe Events that is responsible for the styling of the Events Calendar. Please contact Tribe Events support and show them the following screenshot. Contact them to learn how to add padding to the calendar.


Hi There,
Here is a link to a screencast that shows you what happens when I try to use the layout builder:

Also, once I add The Content element, how do I edit it? I read the section on dynamic content found here Then I added a text element, found the little icon, checked the list, but there is still nothing to suggest that I could add the month view of the events calendar.

Sorry to be so dense about this, I really appreciate your help.

Hey @NLeVasseur,

Your Layout Builder setup is incorrect. To keep it simple at first, just add The Content element only. You can add additional elements when you already know how to use the Layout Builder.

Regarding the preview in the Layout Builder, you first need to Assign the layout to the events page that is not powered by Tribe Events. You only add the event shortcode to the page and that will be displayed by The Content element.

If you still don’t see the correct page preview, you can select it in the Layout Builder Preview Options.


You cannot edit The Content element. The Content element will display the content you insert in the WordPress Page Editor or content area so if you insert the event shortcode in the WordPress Page Editor, The Content element will display that in the Layout provided you assign the layout correctly.

Regarding showing the Month view, contact Tribe Events shortcode if there is a shortcode to display that. Again, you need to insert the shortcode in the WordPress Page Editor and The Content element will display that.


Thanks so much for your response. I did NOT know that the content had to be in the WordPress Page Editor first. That bit of instruction is totally missing from the videos created, and since our site has no blogs, I’m not sure how I would have figured this out on my own. Thanks again for sharing that.

I did manage to adjust the CSS so there is padding around the calendar, and the page looks fairly good as is, so I am not going to spend any more time on this. I do hope the issue is resolved on the next theme update.

Thanks again for your help with this.


Hi Nancy,

You’re welcome! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.