Custom Blog layout & Breadcrumbs

I made a custom layout and my design for the Blog page. But there was a problem in Breadcrumbs: “Auto Draft” appears there instead of “Blog”.

To solve this problem, it’s recommended to specify a blog page in the “Read” settings. But then the custom layout is replaced by the system layout.

I want to have a custom layout and a working “Blog” link in the breadcrumbs at the same time. What am I doing wrong?

The website

Hi Ivan,

Thanks for reaching out.
I have checked your Single Post page and found the Breadcrumb is working fine and showing the Blog with the link. If that is not the case and you are trying to point out something else, please provide any screenshot marked with the issue or any video that helps us to recognize the problem.



As I said above, there are two states:

  1. Screenshot 1 (Reading Settings: Post page is specified)
    When the Breadcrumbs work correctly, but then I can’t apply my custom layout. The web site was in this state today.

Now I switched the web site to the second state:
2. Screenshot 2 (Reading Settings: Post page is NOT specified)
My custom layout is in effect. But there’s a problem with the breadcrumbs. You can see “Auto Draft” there.

Hello @jfolker,

Please edit your Blog page and save those sections as a template. You can do that by clicking the “Make Section Template” at the lower right corner while you are in the builder.

Once you save the template, click the “+” button icon in the upper left corner to create a new archive layout.

Once you have the archive layout, you can use the Templates tab to load the saved section template. You can then assign this archive layout as your Blog Index layout. And also, you can go back and assign the “Blog” page as your Posts Page so that you will have a custom blog index layout.

For your reference, these articles can help:

Best Regards.

Thank you! That was very helpful, everything is working as it should! :+1:

Hello @jfolker,

Glad that we were able to help you. Please feel free to reach us if you have any more concerns.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.