Content Area Modal - Modal Closes When Clicked & Multiple Errors In Admin Console

Hi,

I have two problems with Content Area Modals on SEVERAL websites. In each case they are identical problems both on the public side and in the builder.

In each case I have a Global Block which uses the Content Area Modal. Within the modal is a Contact Form 7.

Public Website
When the toggle is clicked the modal appears as expected. As soon as I try to click into one of the CF7 fields, or anywhere else on the modal, the modal closes without me being able to access the form.

Admin Area
In the admin area of the global block, I get an error message:

This element failed to render. Additional error information may be found in your browsers developer tools

When I inspect the page, there are a whole load of errors showing in the Console. I am using Windows 10 and Chrome. this behavious also exists when a Content Area Modal is freshly loaded into a Global Block’s Column without anything else being added.

As I am getting this on more than half a dozen websites I have so far checked, I assume this may be a bug in the Content Area Modal?

Any help would be appreciated.

Thanks,
Christopher

Hi Christopher,

This is a known issue with the previous version but it has been fixed for this months launch cycle. You can update manually now, or wait until later today and it will show on automatic updates.

We actually revamped how modals work for this update so you can build directly inside a Modal element without having to use Global Blocks inside a Content Area Modal. You can find out more about how all this works by checking out the release notes: https://theme.co/content/pro4-3-x8-3-cornerstone5-3

I’m sorry, I missed the bit about the Contact Form 7 inside the modal. We’ve also retooled how those click interactions work so I don’t expect that to be a problem anymore but let us know if you still have any issues after updating.

Hi Alexander,

Thanks for such a quick reply. I will wait for the update overnight and look forward to seeing the new elements in action.

Many thanks,
Christopher

Hey Christopher,

Pro 4.3.1 is now available in automatic updates! This release contains fixes for several issues, like you have mentioned above, so be sure to check out the changelog (https://theme.co/docs/changelog/pro-4). Please do update to the latest version. After doing the updates, always remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

Regards.