Yoast SEO Modal Issue

I have a formidable pro form in a “Content Area Off Canvas” modal and the button is called “Book an Appointment”. When Yoast SEO is disabled I can click on fields and everything works fine. However, if I enable Yoast SEO and try and click on a field the modal closes. I have disabled all plugins and Yoast is the cause. There is no custom code on the site, just a reference to google analytics.

https://studiodjewelers.com/contact/

Also, there seems to be a possible z-index issue when using a formidable pro form with a date field. The date picker does not show up and I am assuming it is behind the modal.

Hi @turnkeydigital,

Thanks for reaching out.
I have visited the given URL and found the issue you have described. Unfortunately the given credentials are not worked while tried to investigate by logging in. Can you please check it and let us know when it is accessible.

Thanks

Sorry about that, you should be able to log in with that same password now.

Hi @turnkeydigital,

It is the problem with z-index which set with the value of 999999, I went ahead checked by added the value 99999999 and it starts showing.

Please add the following custom CSS code into the Page CSS or Theme Options > CSS.

#ui-datepicker-div
{
    z-index:99999999 !important
}

Please remember that the above code will work if copied as it is and don’t conflict with any existing style.
Please note that the code provided serves only as a guide to help you get started custom coding on your own if there’s no option offered in our theme or the products we bundle.
We really do not provide support for custom codes that means we can’t fix it in case it conflicts with something on your site nor will we enhance it.

Thanks

That CSS worked, did you test out the issue with Yoast on the modal?

Hello @turnkeydigital,

It’s good to know that the CSS works for you.

Be advised that Pro 4.3.1 is now available in automatic updates! This release contains fixes for several issues like you have mentioned above, so be sure to check out the changelog (https://theme.co/docs/changelog/pro-4). Please do update to the latest version. After doing the updates, always remember to clear all caches when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

Kindly let us know how it goes.

I made the update and tested the form. All fields work aside from the date picker, the date picker will show up and once I select a date the modal closes and the date picker is still there. I had to roll the update back because there are a couple minor fixes I cannot address right away.

Hello @turnkeydigital,

We suspect that this is a conflict between the theme and the Yoast SEO plugin. This has already been added to our issue tracker and will be looked into by our development team. I cannot make any promises relating to a fix at this stage. I will add a note to the tracker referencing your report though so our dev team can see there are multiple reports of the issue.

Please bear with us.