WPML not picking up subheadline in page translation

Hello, we are using wpml to translate the page and it occurred that it is not picking up the text for subheadline.
Please advise how to fix this.

Hi @amanjaura,

Thanks for reaching out.
While accessing the french URL, it is redirecting to the main site. It will be difficult to recognize without it will be very difficult to recognize the issue without investigating through the admin dashboard. Can you please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


I’ve updated the notes with the login information.

Hi @amanjaura,

I have checked the French version of the page you mentioned and found that the Text has been added in French but the subheadline is still in the English. I would suggest you change the subheadline by clicking on the flag at the bottom right corner of the page.

Hope it helps.

Hi @tristup,
We have added the french text using edit french translation from “all pages”.
That page is not picking up the subheadline part. See the screenshots

Hello @amanjaura,

You have built the pages using the Cornerstone builder. When you translate it, you should also use the Cornerstone builder. Please follow this documentation guide to properly translate your Cornerstone built pages:

Thank you for your understanding.

Hi @ruenel,
Using that option we can’t use WPML’s auto translate option as it will not show up in there.

Hello @amanjaura,

Since not all the element texts were picked up by the WPML, you can switch back to Cornerstone. All your WPML auto-translation will still be intact. Kindly check out the two URLs in the secure note below:

Best Regards.