WPML Media Translation does not work in pro 4.0.6


Media Translation does not work in pro 4.0.3. images shown original language despite properly allocated in wpml media translation.



Hello Andreas,

Thanks for writing in! Could you please update to the latest versions?
Our latest versions are:

  • Pro theme 4.0.5
  • WPML 4.4.8

This latest release contains fixes for several issues so be sure to check out the changelog:

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

If the updates still do not help in resolving the issue, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Please let us know how it goes.

Hi there

I updated to 4.0.6 and wpml was already updated to the latest version.

Problem still persists.

Media is not translated as shown in the screenshots above.

I attached the webpage credentials.

Thanks for the help

Hello Andreas

I didn’t find the translated version of the respective where the images are placed. If you do not have that I would recommend you to create the same with the translated image. Please let us know if that doesn’t work for you.



Of course I have the translated versions, they are allocated within the wpml media translator and also in the wordpress media gallery. To see it there you have to first switch in the top of the screen to the language you would like to look at see screenshot.

So I chose english and then I see the translated media.

And here you can see it in the wpml media translation. You see that I indeed allocated them.

The images in global block id 460 and also in header id 704 have a translation in the wpml media translator.

So they are allocated but still only the one in the original language are shown (german shown, english not shown).

Would you be so kind and look into the issue once more.

Hello Andreas

Thanks for letting me know the header ID. I checked your header ID 704 that is your German header. It seems that you are using the image element to display the image.

German version.

Now if you click on English flag for the English Header that is your translated Header. If you see that header the Header ID is 770 and the image is same.

English version

Please replace the check it at your end.



That’s not how the media translator of wpml works. You define the english counterpart in the media translator of wpml.

In my last posts I provided you with screenshots that I did this according to wpml.

Now, you are stating that I do need to allocate a different image in the english version of the header 770 which is the translation of 704.

But that is now how it works. The media gallery only gives me the option to select the original language which has in the background the english version allocated. I have no language switcher while opening the media gallery out of the header pro.

No selection of language possible out of header pro

I have it when opening the media gallery in the standard wordpress environment

As you can read here:

It is wrong to upload in the german original language also the english versions. It is supposed to be allocated in the wpml media translation as I did.

Themeco should then show the translated image as allocated in wpml


Hey Andreas,

Regretfully, the builder doesn’t have integration with WPML’s Media Translation. Please translate your content including images as shown by my colleague. Use the builder’s translation flags.


Hi @christian

Thanks for clarification.


You are most welcome Andreas.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.