WPML duplicated pages not working in the Pro Editor


We are using WPML on our multisite along with the Pro Theme. Recently, when we duplicate a page, it seems that trying to open the content in the Pro editor only results in the message appearing : The preview could not load. This is most often related to a plugin conflict or aggressive page cacheing. Checking the developer console for errors could indicate what went wrong.

I cleared every cache we have, and the problem seems to persist. When I look at the page (in the wordpress Dashboad) the content is all there, it just doesn’t want to open in the editor.

Hello @magikweb,

Thanks for writing in! Your issue could be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

  • Testing for Plugin Conflict
  • Theme Update
  • Child Theme
  • CSS/JS Customization
  • Increasing PHP Memory Limit
  • Disabling Cache
  • Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

We found the problem on our own, it had to do with something else.
Thank you for your help anyway!

Hi Magik,

You’re welcome and we’re glad that you’re able to fix your issue.

Hope that helps.

Thank you.

What was your solution here?

We emptied the dynamic cache (SiteGround’s SuperCacher level 2) and it started working shortly after.
We posted here, but the problem came back last Friday, something is not working right between WPML and Pro. We did update WPML, so maybe there’s some glue missing.

Hey @magikweb,

It’s good to know that you have resolved your issue and thanks for sharing the steps that resolved the issue.

It is best that you create a separate thread for your issue.

Thank You.

There are still problems with the latest version of WPML vs Pro.

There are 3 issues that we can reproduce it seems.

#1 After translating a page (to english) and changing its slug (so the URL is also translated), Pro tries to load the older URL in its iframe causing a 301 redirect (which shows the common error). It could be some caching problem, but we disabled all the ones we could find.

#2 The URL to “Edit with Pro” changes depending on the lang get parameter
When first opening “All pages”: https://www.penelopemallard.com/pro/#/content/1372
After clicking “English” to filter pages, it adds lang=en and the URL is changed to: https://www.penelopemallard.com/en/pro/#/content/1372

This may not cause any issue, but it’s a consistency problem for debugging.

#3 (most important) When attempting to edit the page in English, it loads the right page (right tag in the response when looking at the console), but with the french content.

When Pro loads the page using a “POST” it loads french content, but when we browse manually (GET) to that page, it loads the English content. In our example, only the H1 at the top was translated for testing purposes.

In other words, browse this page and it’ll say “Media and events” at the top (good): https://www.penelopemallard.com/en/media-and-events

But when the Pro editor sends its POST to that same URL to load its iframe, that H1 is the french version’s.

Is there anything I can try (aside from disabling all plugins to test for conflicts)?
We have developers, they just wouldn’t know where to look.

Thanks for any help!

Update: Changed #2 with the new discovered (lang=en changes the URL)

Hi @magikweb,

If you are still facing the issue described in the last post, I would recommend you troubleshot a few common issues on this.

1.Theme Related Issue
2.Plugin Conflict
3.Child Theme Related issue
4.CSS/JS Customization
5.Disabling Cache

If that doesn’t help, please provide login credentials for your site in a secure note to examine it further, including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Thank you @tristup,
We disabled all the caching systems we could think of and only did tests with the client-side cache disabled (using the console). To avoid any confusion risks, we just paused CloudFlare. It could still be a caching issue (maybe), but we don’t see which one would be involved in this POST vs GET case.

The secure note will be attached in a moment.

The easy test is to look at those two outputs (they shouldn’t be different).

Hey @magikweb,

I’d like to comment first regarding your previous points.

  1. You can change the URL of the page. Please watch the video below. The problem is with your permalinks and/or server setup. I could still change the URL of the translated page but probably because of aggressive caching or some configuration, the builder could save but intermittently (see video in the secure note).
  1. This is normal and it’s WPML that is doing this.

  1. This is most probably because of caching or server configuration. This could possibly be due to the Multisite setup as well. We can investigate this but please understand that this might take a lot of time and we couldn’t guarantee a fix since WPML works on our sites. This means there’s no issue on our end. The issue is with your specific setup.

We also will need that you copy your site to a staging server without any caching and plugins. Only leave WPML and the Pro parent theme. We can’t investigate on your live site as we need to test deactivating or removing or changing a lot of things.

Thank you for understanding.

1 Like

Thank you for taking the time! The material you made gave us a lead, we will investiage further and keep you posted.

Hi Magik,

You’re welcome and it’s our pleasure to help you. If you have any other concerns regarding our theme features, feel free to reach us.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.