Woocommerce single layouts don't work


Yesterday I worked on a single layout for all of my products after choosing the “Woocommerce single” page that Cornerstone offers. It was working fine until Cornerstone started displaying this error:


So I went and disabled all my plugins except for Woocommerce, but the error persists.

I tried to go around the problem by creating a new single layout altogether and assigning it to “All products”. Unfortunately, the “All products” option or any other option concerning “products” simply does not appear in the menu.

Can you please help?

Thank you.

Hello @Delamour,

Thanks for writing to us.

In order to help you with your concerns we need to check your settings I would request you, please share the admin login details meanwhile I would suggest you troubleshoot a few of the common issues before we investigate your settings. Please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin-level username and password

You can find the Secure Note button at the bottom of your posts


Thanks for your reply.

I’ve removed all CSS and the problem persisted. So I put it back on.

I’ve added the secure note. Thanks!

Hello @Delamour,

It seems that you have performance issues on your site. Please go to Tools > Site Health > Info > Server and check your PHP post max size and Upload max filesize. 8M should be increased to at least 32m or 64M. Please check this out:

Kindly let us know how it goes.

Hello Ruenel,
Thanks for your your help.

Unfortunately, the problem persists. I first tried the options that go into the file manager, but none of them would increase the max upload size, so I downloaded an extension and it did the work:

Capture d’écran 2023-03-19 à 11.06.59

Maybe this info is useful: it says the PHP limit time is 30 and it’s too low.

I’ve tried to increase that limit time in the file manager and by editing the Theme, but it doesn’t seem to be working.

I’ve now removed all those modifications except for the max upload size plugin.

Any ideas?

Thank you!

PS: FYI for the option that suggests to edit the .htaccess file: I don’t find that file in the file manager under Public HTML. When I search for it, it says it’s there, but I don’t see it to be able to open it.

Hello @Delamour,

Can you please clone your site in a staging site so we can investigate further? The staging site is the safest way to troubleshoot this issue without disrupting your live site. If you haven’t done any staging sites before, please check out this article first:

Thank you for your understanding.

Hello Ruenel,
Thanks for your follow-up.

You can go ahead and modify the live site. It doesn’t matter the consequences.


Hello @Delamour,

I was able to figure out the cause of your issue. As it turns out, you have added {{dc:woocommerce:product_id}} in the custom attributes of your Checkout Link button in the custom header.

Please be advised that you can only use this dynamic content when you are viewing a single product or inside a product loop. At the moment, I added a condition to the Checkout Link button so that you can continue editing the layouts in the builder.

Best Regards.

1 Like

Hello Ruenel,
Thanks so much for the fix. It must have been a real hassle to figure it out.
I really appreciate your help.

You are most welcome, @Delamour.