Woocommerce email template additional info

Hello,

My woocommerce email template displays "additional" info line in english, while everything else is translated. Is it possible to hide, delete or translate that line?

Hi There,

You can translate those strings in X language file x.pot located in folder /wp-content/themes/x/framework/lang/. For more detail, please review our KB article on Translation: https://theme.co/apex/forum/t/setup-translation/61. You can use Poedit to translate X language file.

Other option is we can try adding the following code on your child theme functions.php file to translate it:
add_filter('gettext', 'translate_text' );
function translate_text($translated) {
$translated = str_ireplace('Additional information', 'Additional information translation here', $translated);
return $translated;
}

Hope this helps.

Hello,
Thanks for response. However, the code you provided did not work. I have also tried translating x language file with poedit. Did not work as well.

Hi There,

If you have caching, try to clear cache so we can see updated content. If the issue persists, please give us
site URL and admin credentials using a secure note so we can check.

I've added details above

Hello There,

Thanks for updating in! It appears that you are using Loco Translate. Please go to Loco Translate > Plugins and select WooCommerce. You must do a search and make sure that all the keywords were properly translated.

Hope this helps.

It is translated, does not help. I am speaking about email templates of woocommerce. Is it possible to delete that line (additional information) because it does not seem to work with translations.

Hello There,

Thanks for updating in! The additional information in the email may have come from another plugin that adds additional information for the product. If you are going to remove the line, you might need to customize the email template. To do it, please check out this tutorial: https://docs.woocommerce.com/document/configuring-woocommerce-settings/#section-20, https://www.sellwithwp.com/customizing-woocommerce-order-emails/,

If you want to find out where the additional info is coming from, please switch to twenty seventeen theme and start by disabling one WooCommerce plugin extension one at a time and then test you email. You will know which plugin is causing it when it disappear from your email test.

Please let us know how it goes.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.