WMPL issue


In cornerstone, there’s a problem with the different languages.

The French tab shows the correct layout of the page :

But when selecting the German tab, the page is empty !

I edited some elements in the page and then the page in French was the German version !!
I had to restore my site to have both languages again.

Why is the German tab empty ??

Best regards

Hi @baysquentin,

Thanks for reaching out.
There are some ongoing issues with the WPML and the latest version of Pro/X. Our development team is working on those issues and will be fixed in an upcoming release. Till then please stay tuned and keep eye on the updates.



I made the last update but I still have a serious issue :

When I edit the German version of this page

It also rewrites the French page in German…

But this doesn’t happen the other way around. (When I edit the French page, the German page stays in German)

I didn’t try this on other pages… I don’t feel like re-translating whole pages anymore…

(Now I save the template of each page each time before editing something).

I played around in your site a bit and see this issue. Pages seem to work differently in WPML and I’m trying to determine the settings that trigger this currently. I do not have this issue for any other post type. I am working on a solution to this and will update this thread when I have more details. Thanks for bringing this to our attention and apologies for this issue.

Thanks, I appreciate that you kept me informed !

You are most welcome, @baysquentin.

Any update on this ?

1 Like

I’ll be taking another look today or tomorrow. And then if it’s a code change it’ll go up Monday. Apologies for this taking so long I do consider this a big issue.

ok thanks for your reply.

We’ll have a fix for this for 6.1.1 on Monday. Something with WPML was copying page content via their CS integration even without auto-translate or anything like that. Only happened with page types too. It’s more of a workaround, but it prevents the issue at least.

Ok, great, thank you.

You are most welcome.

Just did the update. Now I can’t save the page anymore…

Are you getting any dev console errors?

Not sure what you mean. Can you be more specific ?

See this article. Should see yellow or red text here. I can check it out on your site as well if your comfortable with me saving the page in question.


Nothing here

But I found this :

Even after saving you see nothing there? You should get a message after a failed save.

You might need to turn on WP_DEBUG as well.

Really only one thing was added and I don’t see it causing a save issue as it just disables WPML auto translate. Adding that to the to your child theme will disable what I end up disabling and we can see if that helps.
add_filter("cs_wpml_enable_page_builder_integration", "__return_true")

Ah sorry, I wasn’t in the editor.

Here’s the console error when trying to save :