Vimeo is not displaying properly


I tried using iframes which worked on a page I created a couple of months ago, but the video there is an error message “ refused to connect.” I tried inserting the short code [su_vimeo url=“” width=“640” height=“360”] but the video is displaying full size. I tried the Video Player, but that is displaying with a lot of white space around it. Any ideas why iframes on the page would not be communicating with Vimeo?

Hi Elyssa,

Thanks for reaching out.

To better help you with your problem, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password
  • Link of the page where the Vimeo is located

You can find the Secure Note button at the bottom of your posts.

Thank you.

I added the credentials to the secure login. An iframe generator site was recommended to me which helps, but the formatting is not behaving as expected when I update the sizing and padding. Also, the preview isn’t working. I have to publish the article to see the changes I made.

Hi Elyssa,

Thank you for providing the credentials, can you please specify the page and the section where you are getting the issue. Alternatively, I would request you to check the article on the video element and the embed code here:


Hi, I tried adding video in WP Bakery page builder using Video Player but it adds quite a bit of extra space to the top and bottom with no option to edit like the Video Element shown in Is there another way to access that element? I got the page to look ok on the desktop, but now we are having problems with the mobile site.

Hi Elyssa,

Thee are padding top and bottom 30px in rows. You can adjust spacing from row’s padding values.

Hope it helps.

No, so I suspect you didn’t understand the problem, but I was able to find a work-around.

Hello @MCWebDev,

Glad that you were able to fix your issue by yourself.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.