Unable to use cornerstone/edit website

This morning I am getting an error in the console that is preventing the editor from loading. All I get is a spinning wheel while trying to load. Attached is the error code.


Thank you

Hi Philip,

Thanks for reaching out!

There could be a plugin or custom code that affects your website.

I recommend the following troubleshooting procedures before we investigate the settings.


Only if none of that helps, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Thank you for the quick response. Here is a snapshot of where the error is located.

Hi Philip,

Would you mind sharing your admin credential so that we can check the back-end settings properly? To do that, please add it in the secure note, please refer to the secure note link I posted above.

Thank you.

I added the secure note. Thank you.

I’m also getting the exact same error and can not load Cornerstone since this morning.

The error is pointing to Cornerstone. This is what the system engineers at my hosting service found:

That error suggests a missing variable somewhere. In this file:


We have this line of code within a function definition:

$filename = “$path/definition.php”;

That $path variable is supposed to be passed to the function, but apparently is empty, so it ends up trying to include “/definition.php”, which doesn’t exist and is outside the open_basedir path, hence the error.

I did not find any obvious place where the $path is supposed to be defined within the theme code, so this probably needs a proper programmer to dig into the problem. For now I’ve left open_basedir turned off, which isn’t ideal but is fine until this can be sorted out.

Hi Philip,

I couldn’t access your website due to IP restrictions. I suggest that you disable it for the meantime so that our support staff can debug the issue.

@pixmomedia @mbpz, I suggest that you create your own thread to better assist you with your issue. I also advise that you share your credential in the secure note on the new thread.

Thank you.

I added the ip address listed in the screenshot above to my allow list on CloudFlare. You should be able to access the site now. Thank you.

Hi Philip,

The siteground optimizer plugin is causing the issue to your website. Optimization plugins often combine scripts and reorder them and the common cause of issues as some scripts should not be combined, minified nor re-ordered. That is the case with our products so please contact Siteground or the developers of SG Optimizer to exclude everything from Pro from any kind of optimization. Don’t worry, our themes are optimized out of the box so they don’t need third-party optimization.

In the meantime, I suggest that you disable the siteground optimizer plugin and the builder will work properly.

Hope that helps.

Thank you.

I didn’t create my own thread because I was hoping this thread would shed some light on the exact same issue I was having, and that it did!

I am also using Siteground and disabled that plugin for now and it worked!
I disabled every plugin EXCEPT the Siteground plugins this morning, go figure haha.
I just found it odd that my other Siteground website is still able to access Cornerstone with the plugin running. Probably in the config somewhere.

Thanks a bunch!

Hi @pixmomedia,

I am glad that my solution to the issue is also fit with your problem! If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.