Unable to revert back to cornerstone older version after updating to version 6, E_COMPILE_ERROR` was caused in line `8`

I tried reverting back to the older version of cornerstone after theme x caused some issues (reported in a separate topic). The issue with reverting back to the older cornerstone is this:

An error of type E_COMPILE_ERROR was caused in line 8 of the file /public_html/wp-content/plugins/cornerstone/includes/classes/classic/utility/class-shortcode-preserver.php . Error message: Cannot declare class Cornerstone_Shortcode_Preserver, because the name is already in use

I updated to version 6, I had no choice as the website wont load. Please advise.

Hi @Bark201,

Thanks for reaching!

Would you mind sharing your credentials so we can take a closer look at the site? To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password
  • FTP Access

You can find the Secure Note button at the bottom of your posts.

Thank you.

Unfortunately I cant, I have sensitive info.

Hi @Bark201,

I wanted to add some additional context here. In Cornerstone 6+ that file should be located here:


But in your install it claims to be here:


I suspect what might have happened is the new files were added, but you still have the old files present in which case it would find both and crash like this.

Did you happen to update manually using FTP or a file manager? Often when updating that way it will replace existing files, and add files that don’t exist in the new locations but it doesn’t know to delete files that were relocated.

I would recommend fully deleting Cornerstone and reinstalling. A good way to do this would be:

  • Fully delete Cornerstone
  • Ensure X is on the latest version
  • Use the link provided by X in the dashboard to automatically install Cornerstone at the latest version.

Let us know how that goes.

In restore it overwrites the files so perhaps deleting it completely might work. I will try it but not right now. I cant use the the latest x version because it causes issues. I provided screenshots in:

Ok, I’ll followup on the other thread and we’ll try to get everything solved there instead of having two open which will save some back and forth.

I opened this thread because its a separate issue. Others may have issues restoring. You can merge them if you find it better this way. Although its a separate question, is there anyway to disable cornerstone FA (brands) without theme options as I cannot access it with the new version of cornerstone?

Ok, I think the best thing to help us make sure your issues are resolved is to keep one line of communication on the other thread. I replied there about Font Awesome as well. Thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.