Typography not responding on the website

I’ve set the font on the website in font manager and without font manager to be Abhaya Libre and its not just that … it has Montserrat and Muli and everything in between. So my question is what do I need to do to make it a single font website, do I need to code it myself or what?

Please help!

Hi Aleksandar,

If you have added the font in the Font Manager, kindly set the Typography settings in X > Theme Options > Typography.

If you already set the settings correctly but there are still items that are not set to the global font, kindly provide the link to the site so that we can check it.

Hope this helps.

Hi Jade, thanks for quick reply.
I have set the settings correctly to Abhaya Libre and there is some text that is not that font so I need another way to make it a global font … here is the website in question https://www.off-shore.net
Thanks in advance!

Hi Aleksandar,

Thanks for providing the link. For the main menu links font, please change it in X > Theme Options > Header > Links – Text > Navbar Font and set it to Inherit or Abhaya Libre.

As for the other texts that are set to different fonts, they seem to be set through custom CSS in the Global CSS. Please check it in X > Theme Options > CSS:

Hope this helps.

Thanks for your reply … so I have this code in css:
@font-face {
font-family: ‘Montserrat Extra’;
src: url(’/fonts/Montserrat-ExtraBold.eot’);
src: url(’/fonts/Montserrat-ExtraBold.eot?#iefix’) format(‘embedded-opentype’), url(’/fonts/Montserrat-ExtraBold.woff2’) format(‘woff2’), url(’/fonts/Montserrat-ExtraBold.woff’) format(‘woff’), url(’/fonts/Montserrat-ExtraBold.ttf’) format(‘truetype’), url(’/fonts/Montserrat-ExtraBold.svg#Montserrat-ExtraBold’) format(‘svg’);
font-weight: 800;
font-style: normal;
How do I change that to Abhaya Libre?

Hello Aleksandar,

The @font-face custom css is not needed. The font family that you are trying to use is part of the Google fonts.

You should be able to set the fonts for the whole site in the Theme Options > Typography. The problem is that somewhere in the custom css, you added a custom css that uses another font. You will have to find that css and remove the css. If you cannot locate it, please provide us access to your site so that we can figure out where did you have added it and check your font settings as well.


1 Like

Thanks a lot … it was in the css and I changed it now and everything is just one font on the entire website.

You’re welcome!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.