The grid fails to create new grids

Hi, Im on WP 5.5 and Im trying to create a new grid in the grid. When I click new grid, Im just taken to a blank page. Ive cleared all my caches but it still happens. Ive even tried cloning and existing (working grid) but when I add the short code to the newly created grid, that fails to load properly.

Are there known issues with The Grid with the WP5.5 update?


Hi @wbc,

Thanks for reaching out.

WordPress upgrade can be the reason for this issue, we are currently testing our themes and plugins with the updated version of WordPress, theme and bundled plugins will be released after it has passed our test.
Please check the version compatibility page if the latest versions of plugins are already available.

I would suggest you downgrade the WordPress version of your website, till the updated version of the theme & plugin is released.
To downgrade the WordPress version you can get help from here:


Ive downgraded to 5.4.2 still getting the same problems.

Hello @wbc

I would suggest you downgrading WordPress to version 5.3. 5.3 is the recommended version and the one we currently support.
Please also check the plugin version compatibility page if the latest versions of plugins are already available.


Hi, Ive downgraded to 5.3 and Im still getting the same problem

Hi @wbc,

To better help with your concern, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

Hey @wbc,

I tried to login with the given credentials but they aren’t working on my end and I’m also locked out of the system by your security plugin. We released an update for The Grid plugin few days ago, try updating the plugin and see if this resolves the issue. You can find the latest version numbers here

To update any extension, please follow 'X' Theme will not save any updates

Let us know how this goes!

Hi, Nope afraid not. Im running the latest version 2.7.6. Ive downgraded Wordpress and still getting the same problem.

Ive reset your credentials. Ill update the secure note.

I have tested these credentials and they work for me.

Can you please try to log in again and see what the problem is.


Hey @wbc,

I’ve replicated this issue using WP 5.5 so I downgraded WordPress in your staging site to 5.3 using the WP Downgrade | Specific Core Version plugin and that solved the issue. I created 4 grids to double check.

  • 1st grid was created after downgrading WordPress to 5.3 while theme was switched to 2020 and all plugins deactivated except The Grid.
  • 2nd grid was created after activating all plugins
  • 3rd grid was created after activating X parent
  • 4th grid was created after activating your child theme

Please try all of that in your live site and just note that we do not provide support the WP Downgrade | Specific Core Version nor any 3rd party plugins so you should contact the plugin author if you encounter issues or need support.

In the changelog of The Grid, version 2.7.6 includes support for WordPress 5.5 but we’ve receive similar reports stating issues encounter with the said The Grid version. There could be some variable that might have been missed. It could be a conflict with a PHP version so you could also try downgrading to PHP 7.2 and update WP to 5.5 though in my test site, even downgrading to PHP 7.2 still won’t work. I’d recommend though that you stay tuned for the next The Grid update maybe a fix will be included.

Hope that helps.

Thanks thats helped. Ill look out for updates and will move back to WP5.5 then.

You’re welcome. Glad we’re able to help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.