The grid Facebook feed permission denied

Hello, as mentionned in this post: The Grid Facebook Error i’m having the same issue. I submitted my facebook app for review and came back negative. I just want to share on my website the content my facebook page has. Can anyone help?


Hello @idylliq,

Thanks for writing in! Please make sure that you are using the latest version of the plugin. You can check out the latest supported The Grid plugin on this page:

It could also be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

  • Testing for Plugin Conflict
  • Disabling Cache
  • Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

i have 2.7.3 grid plugin, but i dont think it has anything to do with that, unless i’m wrong. The issue is that it tells me i need to get facebook permission. But the app i created with facebook for the permissions was rejected by facebook. And it seems SO complicated th steps they ask (screencast, driver’s licence, etc) just to be able to post my own data from my fb page to my site.

Hello @idylliq,

Thanks for the information. Just a few hours ago, we have release the Grid 2.7.5 which is the latest version. Please have your plugin updated. After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

Best Regards.

Thank you for the response. I just updated the plugin and cleared all the cache. It still gives me the same error. I’ll try to explain in another way:

Do i absolutely need to have my facebook app ask those permissions? if so, did anybody else have an issue? because it seems that facebook doesnt approve my app because i’m asking for ‘pages_read_user_content’ permission or the ‘Page Public Content Access’ feature. Facebook says they dont think my app needs those permissions.
Have you tried using the facebook feed feature on your plugin? did you have to ask for those permissions? were they approved?

You can have a look here at my client’s website i’m working on right now where you can see the error:

So in conclusion, here is my question:

Am i using the plugin wrong? Or do i need to focus on the facebook app and configure it and ask those permissions (which consist in elaborating a tedious description on how i intend to use those permissions - which is just to use your plugin - and validate my identity upon facebook with a business account verification blablabla)

Thanks for your quick answer!

Hello @idylliq,

I have investigated the issue. This could be a bug between the plugin and the Facebook permissions. We’ve submitted this to our issue tracker so the developers will be made aware of it.

Please bear with us.


Thanks for your respenses! Any luck yet?

Hey @idylliq,

Regretfully, there’s no response from The Grid developers yet. Please stay tuned for updates.


Thank you, i am on stand by. Please keep me posted as this is an urgent matter to me!

You are most welcome.
We really appreciate your kind understanding.

Just to follow up and specify some stuff… Do you understand the problem? i am actually asking myself if it’s the normal process to add my FB Page feed on the grid - the is a load of steps on facebook app to accomplish in order to get it reviewed. i mean, it looks like i’m doing something wrong…
The faceobok error is specifically telling me that it requires the ‘pages_read_user_content’ permission or the ‘Page Public Content Access’ feature. is that normal? and if so, are you aware that we need to create a LONG and complicated request to facebook? Because, maybe i’m just doing it wrong…


Hi there,

Yes, it’s normal, all permission related are controlled by Facebook itself, and the plugin simply displays what was served to it. I had previous work similar to that (but different application/plugin) and it took 2 weeks and multiple submissions before I’m able to make it work. Seems they are more strict now regarding the privacy, but it’s your content so they should allow it :slight_smile:

Their privacy standard always changes, hence that process may fail over time and will further require different permissions.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.