Still cant load page

Thanks. Let us know if the issue persist even in high speed connections.

Could you also try disconnecting your site entirely from Cloudflare?


Hello, have following to report.

  1. Tested website on fairly high speed (20 mbps) with another totally different PC and got the same error.

  2. With the help of WPEngine staff we totally disabled cloudflare and had site offline for about half an hour will running tests. We modified my local host file so that I had direct access to the website while I tried to open pages. Again kept getting same error.

So I have eliminated my PC and network from the problem. Also cloudflare has been eliminated as a problem.

So not sure where to go from here, there seems little I can do now to resolve the issue at my end. Hopefully you guys have some more suggestions.

I should add the high speed test was done on a totally different network.

Hi there,

I understand that you did all of that, but would you mind providing your CF login credentials as well? I like to try it myself: slight_smile:

I can still see CF active from your site and we can verify it through the source code and header responses. And since it’s a live site, then the cache is probably active as well since it’s WPEngine. I’m not saying it’s the culprit, but I like to clear caches at the same time from both WPEngine and CF while testing.


Yes that is no problem I will put the details in a secure note. You may have to take the site offline to test, that will happen when you disable cloudflare. But I am OK with that as we only get about 200 visits per day so wont affect to many people. Anyway good luck and hope you can figure it out.

Here isome more info you may need to direct access site once cloudflare disabled (secure note)

Hi there,

These are what I did,

  1. I changed your CF rules
  2. Under your Admin > Settings > General, I changed you HTTP URLs to HTTPS URLs (that’s because your site is SSL enabled)

And it works

But it still too slow and usually won’t load, something is wrong with it internally. The fact that you’re forcing it with HTTPS but the configured URLs are still in HTTP, then maybe internal URLs are still in HTTP too. Or perhaps, internal URLs are pointing to Staging URL? I see this happen on other sites too with staging feature and the issue is with internal URLs.

I also deactivated the Really Simply SSL plugin since it’s throwing errors that the SSL is still not active.

Unfortunately, we can’t bypass your host caching so I can’t confirm if this is cache related or not (internal URLs).

I think this is also happening on WPEngine’s staging as I saw once from other threads, and the URLs aren’t updated (internal URLs are still the live URL instead of Staging URL). Similar to this ( Seeing the error in a SiteGround staging environment? )


Appreciate you testing it out. What do you suggest I do now. Try to change internal URLs? How would I do that? If it is an internal error would that be difficult to track down.

I should add that I did not change any internal URLs when I went over to https, I relied on the Really Simple SSL plugin to do that for me as I was not sure how to do it myself.

Hey @waynepatt58,

I get the error message every first load but if I click Try Again, the builder loads fine. It seems like it is because you have lots of content on that page. See screen recording in the Secure Note.


Thanks for video, yes I can most of the time get into pages after multiple clicks. That particular page was the worst. I am deleting every section for the states and will just have an accordion that lists every state.

This happens on 90% pages loading. One of your techs thinks it is to do with internal problems related to http links still in a hhtps site so will look into that. So it may be the redirects to https causing the problem.

Hi @waynepatt58,

This link below might help you.

Let us know how it goes.


I deleted most of thee sections on the worst page (gun-laws-state) from 50 down to two sections and it loads fine now. Yet the strange thing is it has actually more content in one of the sections than was in the old page, I basically just stuffed all the content from the old page plus more, into one section. So for some reason (in my case) it seems to relate to how many sections are on a page. The more sections the harder the page is to load. It does not seem to matter if the sections have little or no content either. If I setup a page with 50 sections and no content in the sections it will struggle to load.

So just thought I would let you know my findings in case it can help you pin point the problem. Feel free to go and check that page I mentioned out.

Hi there,

First of all, we want to acknowledge that it’s been about a week this problem persists and we do try our best to pinpoint this issue for your environment. I personally want to thank you for your patience and cooperation and information sharing with us to give ideas what might be the issue.

Your latest reply made me thinking what if our builder cannot handle 50 sections with normal resources, I did a test both on my local installations and one of the live servers by adding 50 sections and adding a simple Alert element inside each. I saved a template of that page and imported to another page on both installations. All of them worked with no issues, both the original and cloned pages.

Then I tried to add a page to your installation with the same template. You can see the page called Many Sections Test Page.

Unfortunately, on your installation, the sections are not even showing, but the front end shows all the alert elements.

Would you please share the information above with the hosting service provider support and ask them if they have any idea of possible restriction in a number of connections made to a page or maybe there is a restriction of the simultaneously ajax calls?

Unfortunately, our knowledge of the ins and outs of the server configuration of the hosting is limited.

Thank you.

Thanks for the awesome support Chris. I tried to open the many sections page and got the usual error message
However on clicking the TRY AGAIN button the page did open.

This is proving a difficult one to track down but I think we have made progress. Not sure why it would not open on your end of things. I dont think this is to do with the host as I originally encountered this error when GoDaddy was hosting the site. This made me think it was due to inferior hosting and prompted me to upgrade to a much faster host WPengine. This did not fix the issue and so the error has displayed on both hosts. And I doubt they would both have the same configurations. The error only started appearing when I upgraded cornerstone and xtheme about two - three revisions back (it was the update that gave us some of the Pro features). Until then everything was working fine.

Regarding the page that was fixed (gun-laws-state) the original content in the 50 sections was pretty basic, headlines with one row divided up into 5 columns and text and some shortcode for icons. The same code was put into the reduced section page. the only difference is that it was placed into an accordion so there is probably nothing wrong with the coding of the contents as it works.

I will include my login details (secure note) for the host WPengine so if you want you can dig around and see if there is anything out of the ordinary.

I should add that one of your other support team, RAD I think his name was, thought the issue may be to do with http to https redirections. I have tracked down quite a few old http URLs and updated them but did not really have any effect.

Hey @waynepatt58,

The issue does not happen on my end anymore. The only difference from the last time I checked was my browser cache is cleared. See screen recording in Secure Note.


Thanks for video. Cleared my cache but still same error on both those pages. Only thing I can think of now is location we are accessing site from. I am in New Zealand so maybe there is some delay between me and the host and you are closer (not sure what country you are in) to the host so not as much delay. Is that plausible?

But definitely seems like a timing issue, do you agree?

Hi there,

Thanks for posting in.

It’s possible, the distance may cause delays too. But, seems this also related to WP 4.9, I noticed that this is common on that version. Plus, 4.9 has many issues as well. How about setting up a site for 4.9 and another for 4.8 (the previous stable version) and let’s compare them both?



This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.