Some Archive Layouts work and some don't


I have made a number of Archive Layouts on one site. One Archive Layout I called ‘global’, it has priority 0 (I changed it to -1 at first, but later back to 0 and it stayed in place unchanged) It is assigned to ‘Blog’ and ‘Archives’.
Than I have a number of Archive Layouts assigned to specific categories or tags, with priority -1. I have made one and later was copying that existing layout and changing the settings and customization.
Now the problem is that a few of those Layouts fall into ‘globa’, although their position is lower than ‘global’. Most of them work well. Those few which don’t work show the right content in the builder (with the right post tag preview) but on the front end they show ‘global’ layout.
I cannot figure out, what is causing the problem. I have cleared the cache, I have changed cache plugin to exclude categories and tags, I was trying to change priority to even lower, nothing works. Most of those archive layouts worked on the day I have made them, but fell into ‘global’ after a few days…
Could you please help me to find out where the issue is?
I am attaching screenshots of front end and back end of one of those malicious Layouts.

Hello @tashitendrel,

Thank you for the very detailed post information. Your Blog layout should be assigned as your Blog index having a condition of Blog>is being Viewed`.

And your Archive layout should have the condition of All Archives


The rest of the pages will have the global layout or your custom page or post.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

I have saved Secure note. Please check.

Hi @tashitendrel,

Unfortunately, I am getting 503 Service Unavailable Error even after logging into your website. Can you please check and let us know once it is accessible.


Sorry for that. Yes, it should be accessible now.

Hi @tashitendrel,

You may need to add the condition on the Global layout to skip the specific archives to be implemented with it. I went ahead and added the Post Tag condition into the Global layout, and found that the specific tag is not loading with the Global one.

I would suggest you add the same conditions for all other archives in the Global layout.

Hope it helps.

Thank you for trying. it looks logical but it doesn’t work. Not only that the tag you have excluded is still not displaying the correct Archive Layout, but also the ‘global’ Layout (modified with that added condition) stopped showing up properly and now it shows some default layout. So basically it is worse. Not only that those troubled layouts are now showing up, my new ‘global’ one also disappeared from the front end…
Just to be safe I have turned the position of all the new tag/category layouts to -100 and global one to -5, but doesn’t help…
I also have plugin “Custom Taxonomy Order”, which I have deactivated, but it hasn’t changed a thing…

Just to add: My custom global Layout on front end should show up on for example that link: Now it gets to the list of the layouts, which don’t show up on front end.

Hello @tashitendrel,

Please take a look at your Condition:

This layout will only display if all of the condition is true. If any of the condition is FALSE, the layout will no longer display. It is best that you change your condition to OR logic so that the layout will display if any one of the conditions is TRUE.

Kindly check out this documentation instead:

thanks for reply. Well, that kind of conditions were suggested by your colleague above. I have changed it to ‘or’ and the custom ‘global’ layout came back, but still it hasn’t resolved the initial issue of some Archive Layouts not showing up on front end.
I am attaching 2 screenshots with current set up on the ‘global’ layout and ‘tibetan’ one. And still, tibetan doesnt show up on front end. On the back end everything looks fine.

Hello @tashitendrel,

Since you want to exclude a particular tag, you will have to use “All Archives” and the “AND” logic.

And please do check the Priority number of the layout.

I’m sorry, but we have already been there. After you changed that setting on ‘global’, that ‘global’ layout disappeared from the front end. When you change that setting, please check how it looks on the website, I gave the link to do it in one message above.
If everything was working well, I wouldn’t be here explaining the problem over and over again. But it doesn’t…

Hi @tashitendrel,

Can you please try once by removing the condition All Archive? I have added the same condition which worked previously and found it working. The first screenshot shows the Global Layout is loading on the specific tag page, whereas after adding the condition( shown in the screenshot ) the page loads with a different layout.

Global Layout:

Condition Added for specific Post Tag:

The output:

If that is not the case and you are trying to point out something else, please provide any screenshot marked with the issue or any video that helps us to recognize the problem.


Well, I just want to let everyone know that the problem was caused by the big number of Archive Layouts and I guess the memory limits. To solve it I had reorganize my tags, put images into tag’s descriptions instead of Layouts and design them mostly on the dynamic contents.

I would like to also request Search Results Count in the query to be added in the future.

Hi @tashitendrel,

Thanks for letting us know you got it worked out.

Under Query in Dynamic Content there is a Found Posts option. This is the total number of posts discovered by the WordPress query. On search layouts it will be the total number of search results. Combine that with the Looper Count option you can do something like “Showing: 10 of 1234 results” in your search layouts.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.