Slider Revolution Video not showing correctly on phone and ipad. Help

I aded a youtube video to my homepage using slider revolution. In order to have no lines showing i had to use the clear after I saw in another blog and change the margin bottom:

I’m not sure if this was the best way to do this because I notice that on my cellphone and ipad I can’t see the play, pause, rewind, fast forward controls. Can you advise on how this should be done so it shows up correctly on cellphones, tablets, and pcs?

Also on a 15inch monitor the video expands across the entire screen, but I have a 27 inch monitor that I’m using, on my 27in, the video looks like this:

How do I get this to show accross the entire screen regarless of what monitor I’m using?
How do I fix these issues

Hello Otha,

Thanks for writing in!

Please make sure that the width of your video element is set to cover the entire scene. See the screenshot below:

If this is NOT helping, provide us access to your site so that we can check your slider settings. Please create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

I forgot all about this, working on this now thanks for your patience

Hey Otha,

The setup is tricky with Slider Revolution and it also is heavy on your page so it’s not good for SEO. May I suggest an alternative setup. Step by step instructions below.

  1. Get the Video Embed Code on Youtube.
  2. Add a new section to your page and set all Paddings to 0
  3. Set the Global Container of the Row within the Section to Off.
  4. Add a Video Element
  5. Paste the Embed Code in the Video Element Embed textarea.
  6. Adjust the Aspect Ratio of the Video Element if needed.

Video walkthrough of the instruction available in the secure note.

Hope that helps.

Will try this today. Thank you


Great, let us know how it goes.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.