Slider revolution error v. 6.3.6

Hi,
I got Slider Revolution installed from the PRO validation-page. When i try to add a new blank slider from the Revolution Slider-page in wordpress admin center I get the message “Could not create slider”. I cannot update the addon to see it that fix it, cause I need a activation code to update, so now im kinda stuck. I have the latest version of PRO.

Best Regards
Tina

Hello Tinami,

Thanks for writing in! The Slider Revolution 6.3.6 update should be available in your Automatic Updates in Dashboard > Updates > Plugins. The error message “Could not create slider” could have been caused by another 3rd party plugin, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

Testing for Plugin Conflict
Theme Update
Child Theme
CSS/JS Customization
Increasing PHP Memory Limit
Disabling Cache
Disabling CDN

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Hello Tinami,

I have logged in to your site and I can confirm that you cannot create a slider. It is displaying “Could not create Slider” error message. This could be caused by a plugin conflict, amongst other things. Please check out this troubleshooting article here and follow the instructions for the following sections (where appropriate):

Testing for Plugin Conflict
Child Theme
CSS/JS Customization
Increasing PHP Memory Limit
Disabling Cache
Disabling CDN

If after trying all of the above things you are still experiencing problems, please give us permission to put your site under construction mode so we can test a plugin conflict in your site.

Best Regards.

Hi,
Thank you.
I have troubleshooted on all areas suggested and nothing helped. Please feel free to put the site under construction mode and do whatever necessary to fix the error.

Best regards.

Hi Tinami,

I have done the basic troubleshooting on your website and the issue still persists. Would mind sharing your FTP access on a secure note? because we need to check the .htaccess and wp-config.php files if there’s some unusual code that preventing the slider revolution not to create a slider.

Hope that helps.

Thank you.

Thank you! I updated the secure note with the requested info :slight_smile:

Hi Tina,

I have checked your site by enabling the WP_DEBUG at wp-config.php and it shows the following errors, related to the Slider Revolution.

Unknown column 'type' in 'where clause']
SELECT * FROM wp_alerigo_se_revslider_sliders WHERE `type` != 'folder' ORDER BY 'id' 'ASC'

WordPress databasfel: [Unknown column 'type' in 'where clause']
SELECT * FROM wp_alerigo_se_revslider_sliders WHERE `type` != 'folder' ORDER BY 'id' 'ASC'

WordPress databasfel: [Unknown column 'type' in 'where clause']
SELECT `id` FROM wp_alerigo_se_revslider_sliders WHERE `type` = 'folder'

WordPress databasfel: [Unknown column 'type' in 'where clause']
SELECT * FROM wp_alerigo_se_revslider_sliders WHERE `type` != 'folder' ORDER BY 'id' 'ASC'

WordPress databasfel: [Unknown column 'type' in 'where clause']
SELECT `id` FROM wp_alerigo_se_revslider_sliders WHERE `type` = 'folder'

To investigate and experiment on the issue, I would request you please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access in the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password
– FTP/ CPanel credential

To create a secure note, click the key icon underneath any of your posts.

Thanks

I have now set up a backup of our site, so you can log in to freely test what you want to test. I dont have any cPanel credential, though. Only FTP. See secure note from before.

Best Regards

Hey @ALerigo,

Your web host blocks Slider Revolution scripts. Please contact your web host to fix what is blocking the scripts. It is only them that could fix the issue. Show them the following screenshot.

Regretfully, since we are not in complete control over the server, we could do nothing for this case.

Thank you for understanding.

Hello again,
I have been in contact with my web host now, showing them this thread, and they are telling me that they isnt blocking any scripts and have several customers where the plugin works fine for, so the problem isn’t caused by them. What’s next?

Hi Tinami,

I suggest that you ask your hosting provider to reset the file and folder permissions of your website or you can check this article on how to reset the file and folder permissions manually.

Hope that helps.

Thank you.

Hi again,
It did not work :frowning: Any other ideas?

Hi Tinami,

I have checked it again by adding the following debug setup code to log the error into the file name debug.log inside the wp-content folder.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
//SET PHP INI DISPLAY ERROR FALSE
@ini_set( 'display_errors', 0 );

But unfortunately, the debug.log file has not been created into the specified folder. It seems that your hosting is not allowing you to create the file on the fly to capture the errors.
I would request you to contact the Hosting service provider once again to look after the matter and let us know the feedback from them.

Thanks