Significant Cornerstone Lag

I have been encountering a ton of lag in the Cornerstone editor recently - particularly with text elements. It takes them a long time to render out. I have disabled plugins one by one to see if that was the issue, but to no avail. As I edit a page or post it is as if it can’t process in the edits in real time. It can take up to 3-4 minutes to make the edits and save. X, Wordpress, and all plugins are up to date.

Hi Joe,

Thank you for reaching out to us. This could be related to the PHP memory limit exhaustion, I recommend that you increase your memory allocated to PHP. To increase it, please edit your wp-config.php file and insert these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

You can add it before the line

/*That's all, stop editing! Happy Blogging. */

Let us know how this goes!

Thank you for the reply. I have already checked this and my memory limits are correct - they are as above. Are there any other possible solutions?

Hey Joe,

To improve your site for a better performance, please check this knowledge base article:

Hope this helps.

Thank you for this. I have been through all of the content and have followed the instructions prior to my post. My site is running fine for users. I am having issues within the editor itself - end users are having no issues with load speed. I have been running the same site on the same host for quite some time and have not had this problem. Is there any way that someone could take a closer look to help me determine my issue?

Hey Joe,

I checked your sites and they’re not up to date yet. One site is still in 6.3. A performance improvement was added in version 6.4 of X. See

Please try updating your sites and see if you notice a performance improvement.

If updating does not help, please give us access to your WordPress Admin and FTP in a Secure Note


Hi Christian - thanks for the quick reply. The site that I am speaking of is and it is running 6.4.6

Credentials coming in a secure note. Thanks!

Hi Joe,

I checked and your Wordpress is updated in which PHP requirement would be 7.2 and up. Please upgrade your PHP version to 7.2 first then we’ll continue. Please contact your hosting provider for the upgrade, the process may cause issues if you configured while other software are old. That’s so they could fix incompatibilities due to upgrade.


Hi Rad,
PHP is updated to 7.2


Hi Joe,

Are you still having issues after the update?

I check and it seems to be working fine on my end now.
I tried to edit some text elements in your site and didn’t experience any Lag.
Can you try editing your page in Chrome Browser.


Yes, I am still experiencing the lag. It has gotten slightly better, but for instance, I typed in some text just before I started this post and it still has not shown up in the live editing window. I am editing in Chrome - the browser that I always use. Should I try something else, perhaps?

Hi Joe,

Thank you for all the information. I added a new page and tested the case with one Text element and it is a little bit slower than a normal view would be. Unfortunately, I could not find why this is happening. Now, the problem is that if the count of elements goes up the slowness will be higher and higher.

This is not the case in my installation both in my local and live versions. This shows that a problem other than the internal code of the Page Builder is the problem cause. In general, there are two reasons for such cases:

  • The bad quality of the server. That means even if you make the settings up and proper the quality of the machine behind the server matters, how much CPU and RAM usage are on hand and, … The only way to test this case it to move your website to another server or your local machine and test the speed. Click here for the official documentation of WordPress on how to move the website.

  • The 3rd party plugins also might cause such an issue. The way to test that is to disable all the plugins except Cornerstone and check the case. As you have the cache plugin make sure that you clear the cache and check the website with another browser.

I personally have a good experience with Chrome, but you are right in some fringe cases, the extra extensions of the browser can cause problems. You are welcomed to test the case with other browsers and another machine on that.

Finally, you do not need to wait for the preview to show the text changes to save your changes and check the case on the front end of the website. So in worst case scenario you can still save the page before having the preview updated.

Thank you and regards.

Thank you so much for the insight. Regarding the save issue, the lag actually affects the saving capabilities. When I click the “save” button, the green process line moves to about 90% and then can take 3-4 minutes to complete the save. I will check some of the other items that you mentioned and if I find the culprit, I will let you all know. Thanks for the help.

You are most welcome.
Please let us know how it goes.

Just to wrap things up, I found that the issue was the I was maxed out on my space on my server. This was causing the server to not respond. All in back to normal now. Thanks for the help - in the process I optimized my site significantly!

You’re welcome. Glad to know you were able to figure out what was causing the issue.
Have a great day! :slight_smile:

Hi team,

I have done just about everything that I can think of to fix this problem. I went in at the server level and upgraded my storage, I added gzip coompression to everything, and I went through all of the steps listed above. I am still experiencing this lag - it gets worse and worse the more I work and it is simply not efficient enough for my workflow. What should take me 10-15 minutes takes over an hour to accomplish. Can someone help me dig into this issue with Cornerstone?

Hi @jlevitt,

Are you on shared hosting? It sounds the performance is being throttled. And may I know the last changes or action you’re doing before the performance throttling?

If you’re just editing a text content then the host is just probably throttling the number of requests that you could do. For that, please don’t do the editing exactly on the text element, instead, do it in any text editor (like notepad or wordpad) and then just copy and paste the content to the text element.


No, I am not on shared hosting. I will try to do the copy and paste and see if it works.

Sure, please let us know if it improves the building process. Thanks!