Revslider fails to load when tabs is enabled


It seems like revslider is not loading anymore after a recent update, although I am not sure when the issue started happening. It fails to load only when tabs is enabled, and with certain presets. Here is the link :

I tried deleting the addons and reinstalling it but it didn’t do anything. I am not sure what to do from here. Has anyone experienced something similar? Help would be much appreciated.


*Edit : It doesn’t bug when “Zeus” or “Hermes” presets are enabled.

Hello @Gloomer,

Thanks for writing in! What do you slider look like? Did you inserted the slider inside a tabbed content element or is it something in the slide itself? To assist you better with this issue, would you mind providing us the url of your site with login credentials so we can take a closer look at the slider?

To do this, you can create a secure note with the following info:
– Link to your site
– WordPress Admin username / password

To know how to create a secure note, please check this out:

Thank you.


Thanks for answering.

The slider has tabs on the left and there is links to other pages on the slides. It works a little like a glossary. I did not insert the slider in a tabbed content. The slider is actually the only element on the page. The slider loads when I turn off the “tabs” option in revslider. Although, the tabs are required in order to navigate through the slides.

Here is a link to the page :

Hello @Gloomer,

I have logged in and investigated the issue. Yes, you are right. The error appears when you select the styles excerpt for “Zeus” or “Hermes”. This could be a bug in the latest release of the plugin. I will report this to our developers so that they can communicate with the creators of the plugin and be aware of this issue.

Thank you for your understanding.


Is there a way I can have a follow up? Or do I have just to wait for the next update?

Hey @Gloomer,

We will have to wait for the creators of the plugin. They are the only ones who can fix and update the plugin.

Thank you for your understanding.

Hey Gloomer,

I just wanted to circle back on this as we’ve kept this open internally and did some more testing recently to see if this was still occurring. We’ve found that although we can see the issue on your site, on other installs it does not seem to be present. We’ve even tried importing your specific slider in other setups and can see a clear visual difference against your live site. This leads us to consider the possibility that there is an issue within your specific setup somewhere.

One easy thing to check for, that could be the culprit, is a plugin conflict. You can test this by deactivating all third-party plugins (excluding Slider Revolution) and seeing if the problem still exists without the other plugins active. After that, reactivate one plugin at a time to narrow down the plugin that’s causing the issue.

As it’s been a little while since we last spoke, I didn’t want us to jump straight in to your site and start messing around without your knowledge or consent, so if you’re unable to find a plugin conflict using the test above and are happy for our team to do a little more digging, let me know and we’ll test some more.

All that said, we’re not excluding the possibility that this is a bug in the plugin still, just that we want to make sure that we’re doing everything we can at our end to identify the issue and resolve it for you if possible.


Thank you very much for your answer and sorry for coming back after this long break.

It seems like my sliders are getting bugs after every update… The same bug as last time is still there and I tried everything to try to get it fixed, and nothing seems to work. When enabling tabs, the entire slider will either not show at all, or only the span will show but not the tabs (depending on which style I am using). Here is what I tried :

  • Creating a custom style and changing the parameters, and removing them completely.
  • Trying different slider/slide settings
  • Deactivating, reactivating the plugin.
  • Created a new slider with a white background. Adding tabs only made it glitch the same way.
  • Purging cache.
  • Tried the same things with “thumbs” instead of “tabs”, and I am getting the same problem.

It looks like there is a javascript error happening with some of the styles, and none with other styles, although the bug is always there.

I am out of options… Is there anything else I can try?
Thanks in advance :slight_smile:

Hey @Gloomer,

I haven’t found the real cause of this yet but I discovered that the Markup of the Gyges Tabs Style contains div tags and that outputs the " HTML entity which breaks the Slider Revolution script.

To prove that it’s the div tag is causing the issue, I’ve edited the Shady Tabs Style and changed the div tags to span and your slider worked.

This only happens in your particular server and/or WordPress setup though. I’ve tested all my test sites in different environments and your slider works.

With that said, your web host might not be following WordPress standards. Regretfully, we could not go as far as investigating Server and WordPress setups as those are beyond the plugin’s control and therefore outside the scope of product support.

Here are some tests you could do to determine where the issue is:

  1. To check if a server setting is causing the issue, install a dummy fresh WordPress site in the same server and then install X, Cornerstone and Slider Revolution only. Then, import your slider and test if the issue persists. If the issue persists, it’s possible that the problem is highly likely your web host.
  2. To check if the WordPress setup is causing the issue, copy your site to a different web host and test if the issue persists in the other web host. If you do not know how to copy a WordPress site, you’ll need to hire a third-party developer to do this for you. If the issue persists, it’s likely a problem with your particular WordPress setup. In this case, I’d recommend rebuilding your site using a fresh WordPress install.

You can let us know what works and the comparison of your current setup and the tests I’ve pointed out so we could forward this to the makers of Slider Revolution, ThemePunch, so maybe they can take certain environments into account.



Thanks for answering quickly.

When switching divs to span, the slider doesn’t crash anymore, although tabs are not showing. I get a gray strip instead.

I was able to see the tabs on the front end when switching the position of the tabs from “outer vertical” to “inner”. Doing so made the tabs appear, but in a crooked way. The thumbnails are out of place and very blurry.

Also, the thumbnails are acting wierd in the editor.

Parameters seem to be working fine.

Investigating further, I realized that something is changing the dimension of the thumbnail images to 15x15 pixels (the url of the images have “-15x15” at the end). Removing the “-15x15” at the end of the thumbnails urls within the inspector made the images clear, although they are still misplaced (they are on top of the text instead of being on the left side).

I am getting a similar problem with another of my slider, where the thumbnails dimensions are changing to 100x50. Link :

I also realized there is a wierd ligne under the revlisder plugin on the plugins page. I am not sure if that has anything to do with the issues I am experiencing.

These issues don’t seem to be a plugin conflict, as they persist even when deactivating all the plugins except for revslider.

And this is where I am stuck now. I don’t know why tabs are not showing when setting the position to outer vertical and why the thumbnails are changing dimensions and acting wierd.

I contacted my web host and asked if I could have another temporary domain in order to test the slider. Although, if I am understanding you correctly, I would also need to purchase another x theme license to do so.

Please let me know what to do from here.

Hey @Gloomer,

The size issue is coming from the Preview Image Size.

Changing that will fix the sizing issue.

Regarding the layout, regretfully, you’ll need to style it on your own using custom CSS because you need to use span in your site instead of div. Fixing that in your site would require custom development which is outside the scope of product support.

Regarding the license, you don’t have to buy another license because a license allows for 1 production site and 1 staging site. You can read more about that here:



Since our last interaction, I’ve approached my web host and we’ve made some testings. According to them, there is nothing wrong on their behalf.

I tried creating a new dummy website and only installing the theme and plugin. I uploaded the slider I am using on my main site and also created a new slider with tabs, as shown on this page :

The new slider seems to be working just fine. Although, the uploaded slider is still glitched.

Is that of any help for my case? What can we conclude about it?

If it cannot be fixed, I will manually create tabs by adding CSS to global layers. Although I highly prefer not having to do that since the layout will be of a lesser quality.

Thanks again.

Hey @Gloomer,

The web host support just declare everything is good on their end sometimes so in order to clearly see if it’s not a hosting setup issue, you should also test a different web host. There are free web hosts you can perform a test like You can find lots of them online.

We could not resolve this as it’s a conflict with your server and/or WordPress setup and Slider Revolution. The most we could do is report this case to ThemePunch once you have completed the tests I’ve posted previously and sharing with us the result and the setup of your server and WordPress configuration.

Thank you for understanding.