Revolution Slider Blank after Update

Hi guys,

I just updated X Theme on this site as well as all plugins and the PHP version (7.0 -> 7.4).

However, I’m now getting PHP errors on the Revolution Slider page, and the slider itself isn’t loading at all, it’s just blank.


  1. Tested with all other plugins disabled and a default theme (Twenty Twenty Two) - Issue was exactly the same

  2. Searched the forum - lots of people over the years have had this problem, but if a solution is listed at all, it’s to "adjust the global settings as shown in this thread, however, the link is broken and the page no longer exists so I have no idea what they tried.

  3. Used the feature to rebuild the database entries for Rev slider

  4. Verified everything was updated to the newest version. I think there is a .1 version change available with Rev slider, however it isn’t bundled with X theme so I can’t update it. Presumably that’s not the issue.

I’ll include a link to the page in a private note so you can take a look. For reference, I have also attached the PHP errors. The first one seems to be what breaks things, and then the rest mostly show up when clicking the “next” arrow.

Please let me know how to proceed, thank you.

Hello @brianjohnsondesign,

Thanks for writing to us.

According to your given screenshot, it seems that it is a JS console error it is not a PHP error. It generally happens due to plugin conflict or custom JS code. Please make sure you are not using any JS optimization plugin. It also causes JS console errors.

I would also suggest you please make sure Slider Revolution -> Global Settings --->Defer Javascript Loading is OFF.

I would suggest you troubleshoot a few of the common issues before we investigate your settings.

  1. Testing for Plugin Conflict
  2. CSS/JS Customization
  3. Version Compatibility
  4. Disabling Cache

If it doesn’t work for you, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi there,

I had already run most of these troubleshooting steps before, but I went ahead and did all of them right now and the problems persisted even with no theme customizations, only the parent theme, and all other plugins disabled.

All versions are also updated and PHP is 7.4.

I’ll attach login info to a secure note.

Oh, and I did change that Rev Slider setting, too. It did not help.

Hi @brianjohnsondesign,

I have checked your website and added the Slider Revolution to the Test page and found that the issue still exists. If you have already found that the issue persists with the default theme, that means the problem may be with the Slider Revolution itself. But unfortunately, the issue can’t be replicated in my local environment with a similar setup.

I would suggest you please copy your live site to a staging server so we could troubleshoot freely without breaking your live site.
And give us access to the secure note including:

– WordPress Site URL & Login URL
– WordPress Admin username/password

To create a secure note, click the key icon underneath any of your posts.


Okay, I created a staging site. Sharing login info here.

Hi @brianjohnsondesign,

I have deactivated all the plugins, re-installed the Cornerstone, and disabled the Defer JavaScript loading from the Global Settings. And after clearing the Style Cache from Cornerstone > Settings > System > Clear Style Cache it start working.

Screenshot 2022-05-11 142655

I would suggest you try that once in your live server, and let us know if that works for you. Alternatively, you can migrate the staging server into the live server.

NOTE: Please remember to take a backup before you migrate the staging to live, so if anything goes wrong backup can be restored.


Thank you!

I did try your steps on the live server exactly and unfortunately, for whatever reason they didn’t work. I also tried reinstalling revolution slider but that didn’t help either.

So instead I just replicated the dev server over to the live one and called it a day. So it is working now, thank you.

Revolution Slider is very finnicky.

I did notice that on both the live site now and the staging site, if you navigate past the first 4 or so slides, you still get a blank screen and a JS error in the console.

Do you think upgrading to the newest version of Revolution Slider would fix this issue? It’s not bundled with X Theme so I’d have to find it elsewhere.

Hello @brianjohnsondesign,

Kindly temporarily deactivate the WP Rocket and troubleshoot again the slider. There are times that the WP Rocket cache and the browser cache is not synched which will also create issues when viewing the site. Please be advised that our Themeco plugin repository offers available versions that is stable and already tested for compatibility and conflicts. With the latest version of the said plugin, our developers are still doing some test to make sure that there are no conflicts and incompatibility with the theme.

Best Regards.

Hmmmm even with WP Rocket deactivated and my local cache cleared, it’s still the same problem.

I eventually get a console error:

“rs6.min.js?ver=6.5.20:38 Uncaught TypeError: Cannot read properties of undefined (reading ‘transform’)”

Among others. I also tried going incognito and that didn’t help either.

Hello @brianjohnsondesign,

It seems that it was an issue with the cache I went ahead and deactivated and deleted the Revolution slider plugin and then reinstall the plugin, it seems that the slider is working now. Please clear your browser cache and then check it again.

Hope it helps

Hi Prakash,

I’m still seeing it with cache cleared, an incognito window, or even a different browser.

I see the same thing as your screenshot for the third slide, but if you make it to the 5th slide, that’s where things break. It looks like the attached image.

Hello @brianjohnsondesign,

I am another staff checking in. This is what I am seeing when viewing your site.

Please double check your browser cache as well before testing your site. Can you please use private browsing mode? By the way, your hosting provider may have a caching feature. You may need to contact them regarding this if ever they have this feature. enabled by default.

Best Regards.

Hi Ruenel,

I’m a bit confused, because in your video you can clearly see that it’s broken. That’s exactly what I’m seeing. The first 4 or 5 slides work fine, and then it goes blank and the slider breaks completely. In your video, you had to refresh the page before it would even work again.

So… Yes, it’s not a caching issue, although as mentioned in my last post, I used an incognito window in Chrome and also disabled the caching plugin.

My web host does not have caching, I am positive. I’ve been hosting with them for around 8 years and have about 200 sites on this host. They do not cache.

Hello @brianjohnsondesign,

I went ahead and checked your slider it seems that there is no image on slide 5,6. You must add the image to get rid of this issue.


Hmmmm that is true. That explains the white background.

There are still errors though, and you can’t click “back” once you’ve gone too far because it breaks.

But I suppose it’s possible it will go away if we complete these slides. I’ll have the client try it out and we’ll see.

I deleted those two slides and it does work fine now. I’m not sure if they have a setting that somehow breaks things, or if simply missing an image does.

Oh well, it’s working now!

Hey @brianjohnsondesign,

It’s good to know that it is working now. If we can be of assistance again, please do not hesitate to create another thread.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.