Product validation not working this time either

Hi! I submitted a request about this earlier and you told me to contact the host provider. It also wasn’t´t private so I just edited/almost removed it because I wasn’t´t sure how to make it private. Didn’t´t know how to delete it either. I changed the password etc though.

I still have the same problem. I can´t validate the product license and I get this message:
Could not establish connection. For assistance, please start by reviewing our article on troubleshooting connection issues.

But I contacted the host provider like you suggested and this is what they said:

Have tested a little according to the troubleshooting tips (the link you referred to):

404 means that you get in touch with the server you try to contact, but the content / website / resource you requested does not exist.

It’s no problem to contact themeco’s server, from our server. Curl is enabled and it is also allow_url_fopen. You can check the PHP setup here:

So it’s hard to see what’s from our side that leads to the problems. Could you ask the theme authors of the topic to check that everything is ok there, and perhaps further advice on what you can try?

Hello There,

Thanks for writing in! Based on the information that you’ve shared, it looks like you have a curl time out. Could you please add this function in your child theme’s functions.php file:

//adjustments to wp-includes/http.php timeout values to workaround slow server responses
add_filter('http_request_args', 'bal_http_request_args', 100, 1);
function bal_http_request_args($r) //called on line 237
	$r['timeout'] = 15;
	return $r;
add_action('http_api_curl', 'bal_http_api_curl', 100, 1);
function bal_http_api_curl($handle) //called on line 1315
	curl_setopt( $handle, CURLOPT_CONNECTTIMEOUT, 15 );
	curl_setopt( $handle, CURLOPT_TIMEOUT, 15 );

After adding this function, please validate your site again. Please let us know how it goes.

I added this and it still gave me the same response:

Could not establish connection. For assistance, please start by reviewing our article on troubleshooting connection issues.

Hi there,

Thanks for posting in.

Unfortunately, I can’t provide a further recommendation as I’m not sure what’s going on or the exact error. A 404 could also mean that cURL is failing, or certificate error. Would you mind providing your site’s login credentials in a secure note (ADMIN and FTP)?

Then I’ll check it directly what’s going on :slight_smile:


I added a secure note to my last post. Hopefully you can use the login info to login and find out what is causing the problem. Thank you in advance.

Hello There,

Thanks for providing the information. It appears that you are using an older version of the X theme (X 4.2.2). There has been so many changes since we have release updates from then on. The API key were deprecated and being replaced with just the license code. Please update to the latest version first. Our latest versions are:

  • X theme 5.2.2
  • Cornerstone 2.1.3

This latest release contains fixes for several issues so be sure to check out the changelog (

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And with this version, to validate X properly, please do the following:
1] Please login to your account and assign the license ( You need to assign the license to your site using this url: You have to make sure that url you just assign is the same as the one you have in your settings, Settings > General > Site Address
2] Go back to X > Overview again, and insert the license code.

And please review the changes that we made on how you are going to validated your X theme because we made a big change in the process. Please check it out here:

Please let us know how it goes.

This helped very much. Thank you.

Glad we were able to help :slight_smile: