Pro theme breakdown (?) - can't update or install plugins anymore *worried*

Hi team,

love your theme. Started with X and upgraded back then for the next project to Pro. Since then, I became an avid user (everytime I’m starting a new project, I stick with Pro) who also recommends your theme to friends & family :heart_eyes:

This is the first time I am seeking help by starting a new topic. Normally, one can find quite everything in the forum but I think this time I am in deep need of special help bc I get errors regarding installations and updates of plugins. More precisely, I am not able anymore to update plugins - and install some new ones :scream:

I only have this problem at this special domain (all specific information in the ‘hidden detail’-text). Because I use quite the same plugins on all domain setups, I am sadly clueless what these error occurs. Well, frankly, I used 2 plugins that are new to my setup - but were recommended in one of your forum threads. So I am not quite sure about that (plugin 1: “Smush” by WPMU DEV | plugin 2: “BackWPup” by Inpsyde GmbH).
Of course I am using a child theme, so maybe re-installing the theme might fix anything?
In the forum I have seen quite often over the yrs that you are offering to log in and have a quick look on your theme. Maybe it’s a bug caused by i dont know and I only need to re-install the theme? That leads me to the next question: If I uninstall & re-install the theme, can I use the same key for the domain or do I stumble upon problems in terms of “this key was already used…”?

In the following, you find my login credentials. Normally, I have big trust issues, but over the yrs I stumbled upon so many forum threads of users who dared to share their information and it seems that you, the support, just doing a damn fine job one can trust :fire: :muscle: So I want to thank you for all of your help! A forum so big that one can find quickly matching answers that offer specific help and solutions are a big relief! Maybe you can point me at least in the direction so I am able to update / install plugins again…



Hey @dustinjeff,

Thanks for writing in and your kind words. The theme is unlikely to cause such an issue where you could not install plugins anymore though. This usually is caused by security plugins or something in your WordPress setup is causing this.

When I logged in to your site and went to check your plugins, I was kicked out of your site. That tells us there’s something wrong in your setup.

Reinstalling the theme will unlikely to fix the issue also but you can try doing it. Your license won’t be affected as it works per domain.

To also check if this is caused by the theme, first, switch to the parent theme and check if the issue persists. If it does, switch to the default WordPress theme. Since this is a live site, it is recommended that you copy your site over to a staging server you can troubleshoot without affecting your live site.

You could try testing for a plugin conflict. You can do this by deactivating all third party plugins, and seeing if the problem remains. If it’s fixed, you’ll know a plugin caused the problem, and you can narrow down which one by reactivating them one at a time.

We also do offer to login if all troubleshooting suggestions are exhausted and we feel that the issue is likely caused by the theme.


1 Like

Hey @christian_y,

thanks for your fast response :relaxed: Took me a while to try everything suggested. It’s strange that you were kicked out of the site. Never happened to me - either before or after our correspondence. But then again, as we already detected, something is very odd…

Thank you for the clarification regarding the theme. I already switched from child to parent theme and tried to update plugins. But I got the same error notification again. It’s on german but translates as followed: “Update failed: The file could not be copied. wordpress-seo/js/dist/wp-seo-term-scraper-772.min.js.”
I guess the link belongs to the seo plugin yoast, which I tried to update in this case.
I also tried updating ‘LayerSlider WP’ again. The error message only said: “Update failed: The file could not be copied.”. Nothing else, no link or similar behind it.
When I switched from child to parent theme and tried to install a plugin, it worked - strangely. So switching from child to parent theme, I guess, makes it at least possible installing new plugins. But the updates can’t still be made :dizzy_face:

Unfortunately ‘LayerSlider’ deleted itself. I thought I would have been careless and deleted the plugin with the plugins I installed for testing purposes :man_facepalming: I was kinda angry at myself bc I was worried that I would lose all sliders (all slides from the website are gone). When I installed LayerSlider immediately again (Dashboard > Pro > Extensions), the plugin was not showing at the plugins page, where it should be to activate it. I tried to install LayerSlider again, clicked on ‘activate now’ in the Pro Extensions area and was directed to the plugins page where no LayerSlider is shown. I am kinda worried about everything as I don’t want to crash my customer’s site more (all slider gone) :cold_sweat: Would love to reinstall yoast, but now I am really worried that I won’t be able to reinstall it again (or that all settings for every page are lost). For me at the moment, every step is like flipping coins

I downloaded the pro-child theme in my dashboard for comparison reasons (functions.php). As I have seen, the functions.php of the child theme is kinda blank. The function of the child theme on the website on the other hand has code in it which looks kinda important. I can’t remember I ever put something there but as I have no knowledge of php I would really appreciate if you could tell me what is going on. What I can see in the first moment is, that in line 6 is standing “Theme functions for X”. Don’t think X and Pro code works together but I am no expert. I post the code after this message below. An answer if I can delete these lines / replace the old with the new pro-child without problems would be great as I have no idea what these php lines mean. And I am going nuts

Before the LayerSlider fiasco, I also deactivated as recommended all third party plugins. Again. But this time not within the child but the pro theme.I deactivated all plugins except of yoast & LayerSlider, which I wanted to update in the beginning of this rollercoaster of emotions. As you might have seen (or not bc you were kicked out of the site), I am currently not running a security plugin. Except of the theme included plugins (Lazy Load, Smooth Scroll, Layer Slider, Contact Form7, Custom 404 ), I am only using plugins for ‘Cookie Notice’, ‘XML Sitemaps’, ‘Favicon’ (recommended plugin from your staff in another thread), Google Analytics by Monsterinsights, Yoast, Page Link To, Facebook Pixel, as well as ‘Head Footer & Post Injections’ (double-checked the last one, works like a charm on every other setup). Oh, and an ‘Ultimate Cornerstone Addon’. But I also have no errors on other sites with the plugin. Deactivation also did not solve anything.

Please, @christian_y help me out with this. I am going complete nuts as I now feel absolutely unable to do anything as it might result in more crashing or even devasting the whole rest. Every little aspect of the website was planned and no plugin was installed that is unneccessary so the code stays slim & the UI is pleasant. If the content is lost by more crashing plugins, I’m in deep trouble as my customer is an 55 yrs old UDSSR man who doesn’t joke around.

Best regards,

This is the code from the child theme functions.php. An answer regarding this would be a big help:


// =============================================================================
// -----------------------------------------------------------------------------
// Theme functions for X.
// =============================================================================

// =============================================================================
// -----------------------------------------------------------------------------
//   01. Boot Registry
//   02. Bootstrap Class
//   03. Content Width
//   04. Localization
// =============================================================================

// Boot Registry
// =============================================================================

function x_boot_registry() {
  return array(
    'preinit' => array(



    'init' => array(),

    'front_end' => array(

    'logged_in' => array(


    'admin' => array(

    'app_init' => array(

    'ajax' => array()


// Bootstrap Class
// =============================================================================

class X_Bootstrap {

  private static $instance;
  protected $registry = array();
  protected $theme_option_defaults = array();

  public function boot() {

    // Define Path / URL Constants
    // ---------------------------

    define( 'X_TEMPLATE_PATH', get_template_directory() );
    define( 'X_TEMPLATE_URL', get_template_directory_uri() );

    // Preboot
    // -------

    $x_boot_files = glob( X_TEMPLATE_PATH . '/framework/load/*.php' );

    sort( $x_boot_files );

    foreach ( $x_boot_files as $filename ) {
      $file = basename( $filename, '.php' );
      if ( file_exists( $filename ) && apply_filters( "x_pre_boot_$file", '__return_true' ) ) {
        require_once( $filename );

    // Set Asset Revision Constant (For Cache Busting)
    // -----------------------------------------------

    define( 'X_ASSET_REV', X_VERSION );

    // Preinit
    // --------

    $this->registry = x_boot_registry();

    // Theme Option Defaults
    // ---------------------
    $this->theme_option_defaults = include X_TEMPLATE_PATH . '/framework/data/option-defaults.php';

    if ( is_admin() ) {

    add_action( 'init',                               array( $this, 'init' ) );
    add_action( 'admin_init',                         array( $this, 'ajax_init' ) );
    add_action( 'cornerstone_before_boot_app',        array( $this, 'app_init' ) );
    add_action( 'cornerstone_before_custom_endpoint', array( $this, 'app_init' ) );
    add_action( 'cornerstone_before_admin_ajax',      array( $this, 'app_init' ) );
    add_action( 'cornerstone_before_admin_ajax',      array( $this, 'ajax_init' ) );
    add_action( 'cornerstone_before_custom_endpoint', array( $this, 'ajax_init' ) );


  public function init() {


    if ( ! is_admin() ) {

    if ( is_user_logged_in() ) {


  public function admin_init() {

  public function app_init() {

  public function ajax_init() {
    if ( defined( 'DOING_AJAX' ) ) {

  public function boot_context( $context ) {

    if ( ! isset( $this->registry[$context] ) ) {

    foreach ( $this->registry[$context] as $file ) {
      require_once( X_TEMPLATE_PATH . "/framework/$file.php" );

    do_action( 'x_boot_' . $context );


  public static function instance() {
    if ( ! isset( self::$instance ) ) {
      self::$instance = new X_Bootstrap();
    return self::$instance;

  public function get_theme_option_defaults() {
    return $this->theme_option_defaults;

  public function get_theme_option_default( $key ) {
    return isset( $this->theme_option_defaults[$key]) ? $this->theme_option_defaults[$key] : false;


function x_bootstrap() {
  return X_Bootstrap::instance();


// Content Width
// =============================================================================

if ( ! isset( $content_width ) ) :

  $stack = x_get_stack();

  switch ( $stack ) {
    case 'integrity' :
      $content_width = x_post_thumbnail_width() - 120;
    case 'renew' :
      $content_width = x_post_thumbnail_width();
    case 'icon' :
      $content_width = x_post_thumbnail_width();
    case 'ethos' :
      $content_width = x_post_thumbnail_width();


// Localization
// =============================================================================

load_theme_textdomain( '__x__', X_TEMPLATE_PATH . '/framework/lang' );

:point_up: :point_up: :point_up: :point_up: :point_up: :point_up: :point_up: :point_up:


Also I am not able to upload photos anymore in cornerstone page builder. The error message reads something like: “Upload not possible. Please try again later.” or - at another try: “HTTP error”. Can only upload images from (Dashboard > Media) :neutral_face:

Hey Dustin,

I logged in again and first tested the image upload issue. At first, I got the issue “Upload not possible” then minutes later. I’m kicked out of your site.

I went to log in again but there’s an issue so I opened up your site in incognito mode and tested again and this time, uploading of image works in Cornerstone so this looks like a caching issue. Please clear your browser’s cache or try other browsers.

Now for the plugin installation issue, it is only the LayerSlider that is not installing. I’ve tested installing Akismet through Plugins > Add New and also the Email Forms extension through X.

It looks like something in your system prevents LayerSlider from being added to your server. Please contact your host if they disallow LayerSlider. I’m sorry but we can do nothing for this. I’d recommend you move to a better host.

I’ve also logged in to your server and saw that the plugins list in your WP admin is different than the ones in your server. I believe you’ve given us the credentials of another site.

I understand your frustration especially if your client will get angry. But, this is not an issue with the theme (parent nor child) but your WordPress setup and/or host. As you can see in my screenshots, the theme works fine in your site. The issues you’re experiencing are not coming from the theme.

Please consider switching to a better host.


1 Like

Hey @christian_y,

thank you very much for your effort :heart_eyes: I think you might have been kicked out because I was also logged in. As soon as I have seen that the globe was uploaded, I logged out bc I thought that you might be logged in.

Thanks for the tip, Christian. Just deleted the whole cache in Chrome (460 mb). But also had the same problems in Mozilla & Brave ( I even tried Edge :rofl:) some days ago, when I started experiencing issues :sweat_smile:

It’s strange that this occures only with LayerSlider and only on this domain.

I am sorry about the ftp. The login credentials are right but the program for the one-click-installation for WP on the server let this all seem like a mess. The specific WP files are here: / > clickandbuilds > AutoCeramic

Ok, I will write my host that they might block a wordpress plugin. What can cause that a plugin that is included in a theme cant be installed?
I have more pages at this host. They all work fine. So the host company might be interested in what to look for and I am not a programmer…
That leads me to the question regarding the child theme: Do you think I can delete the code from above bc it’s useless to Pro (only working on X) & won’t cause more trouble?

Thank you very very much for your patience,

Hi @dustinjeff,

I see we’ll check ti again once your host replied. We’re not sure why they do that but it’s usually due to content and file names, maybe they have on their list that matches the files in the plugin then blocked it. This is just assumption, and there could be other reasons which only your host could answer.

And yes, you may delete the code (if the active child theme is not for Pro) and just keep a backup in case you’ll need it. It should be okay :slight_smile:


1 Like

Hi @christian_y, hi @Rad,

I had five talks (3 email & 2 telephone) with employees of the different hosts and they all said they have absolutely no idea what I am talking about. They ‘only deliver high speed storage for me to use and do not block anything because they do not care what I upload in any way’. I tried to figure out what’s going on by google-ing bc I thought I might find a solution by myself but the other pages I am using with your theme are also breaking down in one way or another. So your advide to ‘please consider swithching to a better host’ is currently not working anymore. Also the used hoster are seen under the top 10 hoster in Germany. When I started the thread I was worried. Now I am more than that bc everything is breaking apart :scream: :dizzy:
As you, @christian_y already said, reinstalling the theme(s) will unlikely fix issues, so I have absolutely no idea anymore how to fix the occuring errors. I deactivated EVERY PLUGIN on every page but this did not fix anything. Because the pages are hosted differently, I do not think anymore that the errors are caused by them. What is going on? I even do not dare anymore to update the plugins LayerSlider & Yoast on different pages because I do not want to break the different pages. My customers are really pissed (sorry for the language but they are really angry bc I can’t finish any work - and I can understand them in one or another way). At the moment, 3 pages are broken.

On the page we were talking about the mentioned errors still occur (let’s call it page 1).
I do not want these pages to be shown publicly with domain & logo bc it is bad for the branding, so I am going to write more specific below.
On page 2 and page 3 one cannot create a new page with content that is shown on the frontend. I am really worried. What is going on? I am really really really worried bc it is threatening my life.

Need help asap. Don’t think that this occurs bc of blocked plugin or hosting at all, @Rad :no_mouth:


Hi !

I have the same problem since few days. I can’t install a new plugin or update them (about plugin bundled whith Pro).
I’ve try everything (uninstall every plugin, desactivate the cild theme…) but it doesn’t work.

And worst : it’s the same for the sites of all my clients running with Pro :’(

1 Like

Hi @dustinjeff,

That’s just assumption and a request from my end to narrow it down since we’re not sure what’s happening on your site. Plus, this doesn’t happen on our installations and other users which has a different host. This is my first time seeing this kind of issue especially that it’s Wordpress that do the installation, the theme only provides the access to our server where Wordpress can download the files that needed to be installed.

The uploads are only handled by Wordpress and not the theme, and Wordpress uses the PHP functions that rely on host file systems. So it’s still host related.

The error when installing LayerSlider is the same when installing large plugins, like it’s taking time to install then you navigate away or reload the page halting the installation. Then the next installation will fail since some files already exist. So what I did is moved the LayerSlider folder outside the plugin folder as a backup and installed it again, and I waited until it’s finished. The speed of installation and updates depends on the environment where it’s running to, waiting is a must. I’m able to update the SEO plugin too.

Hence, with the main issue on this thread about plugin installation an updates, I think they works okay now.

Would you mind clarifying the issue about those page 1 and so on? Is it still related to the main issue? Maybe there is just some confusion. Is it for the uploads? I’m not able to check it as I’m kicked out the site too.


1 Like

@FloChambolle, please start a new thread about this and link this there. Then please provide your site’s URL, admin, and FTP login credentials in a secure note. We prefer that it’s in staging so we don’t need to touch your live site’s setup while troubleshooting. Thanks!

1 Like

Done here ! :wink:

@FloChambolle I’ve already replied to that ticket.

Hi @Rad,

thank you for the clarification. Also I want to thank you for helping with the plugin re-installation on the page which started the thread. You even managed to keep the pre-error existing slides of LayerSlider. That’s a fantastic result. Thank you very much, Rad!!! :grin: :tada: :sparkles:

I did, as discribed by you, the same thing with pages 1 & 2 (TLDs ‘.es’ & ‘.de’). I saved the folders of LayerSlider & Yoast and installed them again. Now the plugins are updated and the installation of others seem to work, too. Success!

The problem regarding adding new elements / creating new pages is also solved now. After seeing the new thred by @FloChambolle (thanks for joining btw :relaxed:) & the answers of @thai & you, I told my host to increase the cURL to 999 sec. Also, just to be safe I bought a bigger service package of one host so there is more space & better performance. Just did this for one of the two pages for testing reasons as it would not frankly be necessary. Unfortunately this did not change anything. Bummer.

For the last 3 days I searched the web for hosting / php errors and similar bc I wanted to understand this in order to solve problems like that in the future by myself. Also, I wanted to help so you don’t have to spent more time than needed on this problem which seemed never-ending. You pointed out different possible host-related causes which I wanted to double check before ansewring. Don’t want to waste time for anyone. At the end I did not sleep for 2,5 days straigth. I went totally nuts and before falling off my chair bc of exhaustion, I just re-installed the theme as it was kinda my last hope before answering again. And it worked. Feel kinda stupid that I did not tried this at first but at least I can now edit everything again. Dunno why it worked but it did made a difference. Hoooray :balloon:

Just for clarification purposes for other users that might stumble upon this tread, I want to lay out what my problem regarding the pages was. The problem is now solved, everything works fine:


The problem was that added elements were not showing as a preview in Cornerstone and were not displayed on the live page after saving.
For investigation, I created test pages on domains 1&2 to ensure the existing sub-pages do not break in any way. When adding a text element to a section, I did not get a preview of the text itself in Cornerstone (only the text block with the grey ‘T’ on it). After saving the page & looking at it live, only the page title showed up, not the added text. Same thing was for other added elements like images. If I changed the general settings from page template ‘default’ to ‘Blank - No Container | Header Footer’ not even the headline was showing up anymore. So one saw only the header & footer, nothing more.
Strangely, existing pages were shown correctly. I just could not add new content. It was only shown as a new grey element but it was not displayed as usual - neither in cornerstone (preview) nor on the live page.
I stumbled upon this problem when I wanted to add content to an existing page and it was not added. I cleared the cache as I thought it might be coherently but it seemed it is not. Too bad I’m a php noob. LOL. Man, I am so happy now, btw. :nerd_face:

Ppl who are looking to update their theme in the future can find solutions here:


So I want to thank the whole / apex team @christian_y, @Rad & @thai which was involved for taking their time, bringing effort and helping out by trying to finding the answer to the occured errors. Thank you Christian and Rad for having a deeper look via ftp & wp-login. You did a great job and again, I am very pleased using the x as well as the pro theme.

I hope you have a wonderful day!


Hi Dustin,

On behalf of my colleagues, you’re welcome. Cheers! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.