Pro Header Assignment Issues and Ghost Header Displaying

I’ve been pulling my hair out with the new header assignment functionality. No matter what I set, I cannot get it to work, even if I delete all headers but one and assign it to the entire site. It still shows a different header somewhere.

Even when I have deleted ALL headers and don’t even have one displaying in the header selection area, I still get a header! It’s as if there is a header still in the tables with an assignment that I cannot find or get rid of. When I get this header and click on it, Pro will say ‘edit header’ and I select proceed, and all I get is white space and I cannot access the header.

My goal is to have one global header with some elements only displaying on the home page. I’ve tried it with one single header as well as two different headers (one for front page and one for rest of the site). I’ve tried and/or statements, etc. No matter whaat I get I do not get results that make any sense. I think there is a bug. Where are headers stored in the database? How can we tell if we have a ghost header out there?

The IDs of the headers are also different even if I only have one header, so I am seeing another header somehow, even though I cannot access it. I also tried switching from child to pro theme and not difference.


Hi Karen,

Thanks for reaching out!

Base on what you are explaining you have some problem with the Priority. I suggest that you will read this article below.

On the other hand, if you are not quite sure how to do it, we are willing to guide you here. To do that, please give us the following information in a Secure Note.

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.