Pro Editor not loading (spins)

Hi There,

I updated the Pro theme and it initially worked with some strange problems in the interface. I restored a backup from last week, increased the PHP memory allocation and updated Pro and all plugins. Now on most pages the editor won’t load (circle just spins). I disabled all the plugins and that has no effect.

Thanks for any help you can provide.


Hello @kpilcher,

Thanks for writing to us.

It seems that there might be an issue of plugin conflict or cache issue. I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme
  5. Css/Js Customization
  6. Increasing Php Memory Limit
  7. Disabling Cache
  8. Disabling Cdn
  9. Permalinks
  10. Version Compatibility

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • Exact Page URL
  • FTP Details

You can find the Secure Note button at the bottom of your posts


Hi @prakash_s,

I have gone through all the items on your list, I actually did most of them before my initial request.

  1. The theme seems to work fine, I just can’t edit some of the pages using the Pro editor.
  2. Disabled all plugins and it did not have any positive effect.
  3. Theme is updated
  4. No child theme
  5. Deleted CSS with no effect.
  6. Increased PHP memory to 512MB
  7. No cache
  8. No CDN
  9. Changed permalinks to post name with no effect.
  10. All plugins were disabled with no effect.

Unfortunately I am hosting on a dedicated Bitnami server so I don’t have the simple ability to create a staging area. I hope you understand my situation. Also for some reason the secure note option was not available.

Let me know what to do from here.

Thanks for your help.


Hi Ken,

For further investigation we need to log into your website admin, I would request you to share the credential through the secure note option. If you didn’t find that option in the current comment, you can add that in your previous comment too.

Thanks for understanding

Hello Ken,

There is a JS error on the page when you load the builder and even the Theme Options. It seems that PageSpeed is loading an old cache JS file.
Uncaught SyntaxError: missing ) after argument list
Can you please deactivate the PageSpeed feature on your site and test the builder again?

Kindly let us know how it goes.

Thanks @ruenel!

I’m not even sure what PageSpeed is. Is it related to a plugin? I will try to figure it out.


Hello Ken,

The PageSpeed Modules, mod_pagespeed and ngx_pagespeed, are open-source web server modules that optimize your site automatically. Disclaimer: Apache PageSpeed is an effort undergoing incubation at The Apache Software Foundation (ASF), sponsored by the Apache Incubator.

I would suggest you contact your web host to purge all the cache of the webserver then check it again.


Hi @prakash_s,

I went ahead and disabled pagespeed on the server and some things seem to be working better now. I am able to edit the “hypbrid homes” page. However there is still something oddly wrong. I added a Video element with a youtube video and it is not clickable so I can’t play it. I also tried a classic video element and am getting the same problem. I also notice that when I try to add controls that the controls seem to be corrupt (incorrect characters). I removed the controls but the videos still will not play. You can see it on the hybrid homes page (first 2 videos), the video that previously existed works (the third video).

Not sure what is going on.


Hello Ken,

You are using the video element incorrectly. Check out this documentation first:

Use only the “Player” if you can supply the absolute video URL. Insert a Youtube link does not count and improper.

Since your video is from Youtube, you should be using “Embed” and get the embedded code from Youtube.

Youtube Help:

I have edited one of your videos so that it serves as an example.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.