Pro doesn't load

I just get a spinner when I try to load the editor in Pro.
Have tried with the current versions of Chrome and Safari and have tried all the options in the common issues post:
-checked for plugin conflict by deactivating all plugins
-increased PHP memory
-updated PHP version
-cleared caches
-deleted and reinstalled PRO
-etc No joy.

I had this issue a few months back and it resolved itself the following day, but it’s back.

My site is


Hello @bbroder,

Thanks for writing to us.

In order to help you with your concern, we need to check your setting, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hi @bbroder,

I have checked your website and found that the Content Builder is loading the pages, header properly. I would suggest you check once by clearing all types of cache and in incognito/private mode of the browser and let us know if you are still getting the same problem.


No luck. I’ve emptied all the caches I know of in the browsers, my mac and our hosting provider, and I’ve tried on two different laptops. Anything you can suggest would be really helpful. Thanks.

Hello @bbroder,

I am another staff, I have checked your site at my end. It seems that the Cornerstone page builder is working fine at my end. I have checked on the Google Chrome browser version 92.0.4515.107. Can you please let us know which browser you are using? Please make sure your browser is updated, I would also suggest you please be sure you have no browser extension that is blocking and JS/CSS.

Hope it helps

I’m using 92.0.4515.107 (Official Build) (arm64). I closed a few extensions but no change. I don’t think it’s browser related however, as I have the same issue in Safari.

You’re probably right that it’s a cache issue. I must be missing a folder, but I’m not sure what to do.

HI Brian,

I suggest that you try to use the incognito mode in Google Chrome or you may try to use another connection because we are able to load your website on our end.

Hope that helps and let us know how it goes.

Thank you.

PRO still isn’t loading the content editor, I’ve done everything I can think of:
-cleared all caches
-Tried current versions of Chrome, Safari and Firefox
-tried two Macbooks and an iPad (when I first encountered this issue, I discovered I could still access the content editor through the iPad, but now it no longer works either)
-Tried safe/incognito mode in all browsers
-Cleared caches at my hosting provider (Bluehost)
-Disabled Sitelock security routing
-Tried with three user accounts, including the one I set up for your use.
-Tried while in safe mode on my Macbook.
-Updated PHP
-Re-installed PRO
-disabled all plugins.
-More things I’m sure that I’ve forgotten.

I am at a complete loss as to why the theme isn’t working.

Hi Brian,

It seems that you already did all the troubleshooting on your website but I was able to load the cornerstone of your website on our end. I suggest that you try another connection and let see if it works for you.

Hope that helps and let us know how it goes.

I am having the same issue with pro. I’ve tried three different browsers now. Have cleared all caches. When I try to edit a page with in Pro, I just see the circular loading animation. Nothing has changed on my end since the last time I logged in to edit pages two days ago.

Hi @brilliancebrand,

Thank you for writing in, please do testing for a plugin conflict, but before you do this, please CLEAR and DEACTIVATE your caching plugin/features first.

If that did not work, please create your own thread and provide us login credentials on that thread (not here because the original poster will see it).


Thank you for the reply. Seems like the caching plugin that links to my SiteGround tools was the culprit.

You are most welcome @brilliancebrand

Oh my gosh…suddenly it works! I have no idea what happened, or if it was anything I did, but now my site works again…I wish I knew what it was so I could fix it if it happens again. I do believe it has something to do with caching, possibly at my host’s end, but not sure. Thanks for your help everyone.

Hi Brian,

We’re glad that it is now working on your end. If you have any other concerns or clarifications regarding our theme features, feel free to open up a new thread.

Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.