Post not showing on Mobile

I put up a post since the latest update on x theme but the post is not showing on mobile only desktop.

Hello Steven,

After doing the updates, always remember to clear all caches (if you are using WP Rocket, WP SuperCache or W3 Total Cache) when updating so that the code from the latest release is always in use. This will help you to avoid any potential errors.

And please clear your browser cache too. You may use private browsing mode in testing your site to make sure that you are viewing the latest codes from the updates and not the cached version in your browser.

If nothing is helping, provide us access to your site so that we can check your settings. Please create a secure note with the following info:
– Link to your site
– WP login URL
– WP username
– WP password
– WP Administrator Role
- Confirmation that we can access and make changes to your site

To know how to create a secure note, please check this out: How The Forum Works

Best Regards.

Is their a email address I can use to add Themeco as a user?

Hello Steven,

Your issue is because of your Cloudflare cache. Please log in to your Cloudflare account and purge your site cache. You also need to regenerate the minified CSS and JS files in Cloudflare.

Kindly let us know how it goes.

I followed the instructions given however the post is still not showing on mobile… It continues to show up on desktop but not on mobile

Thanks for your assistance

Hey Steven,

I checked on my Android phone as well as iPhone and I see your posts. This means that the issue is only on your phone. Please try reinstall the browser you’re using and also try a different mobile browser.

If that doesn’t help still, please give us the following info.

  • Mobile operating system name and version
  • Mobile browser name and version


i see my posts but do you see the latest post… On desktop the latest post is about coffee grinders but on mobile it does not show that latest post

You can go to on desktop and compare it to mobile and you will see the latest post missing on mobile.

Hi Steven,

I checked your homepage on both mobile and desktop and on the first load the latest post I see on both is What is a Mocha Coffee? (see screenshot)



However when I logged into your admin panel then I could see the latest post about coffee grinders. You can test this by logging out of your admin panel then you will not see the latest post in desktop as well.

This seems like a cache issue, if you have server cache enabled I’d suggest you to clear all caches and disable the all caching tools/plugins temporarily and see this works.

Let us know how this goes!

Hi Nabeel

I only use 7 plugins… as you might have seen, and none are related to cache. I also reached out to the company where the site is and they cleared the cache on their end it but it still does not appear…

As a side note, this happened after I updated to the latest x theme… Do you think that there may be some correlation?


Also I checked with the server company and they say that if they use the IP address that the site appears.

Hello Steven,

I am another staff. I have checked your site on desktop and phone both. It seems that it is working fine on my end. It might be a browser cache at your end. I would suggest you clear your browser cache and then check it again. Please have a look at the screenshot in the secure note.



Thank you for your assistance however I am hoping to have continuity. As I have mentioned previously, the latest post that I did is not showing on the site.

Your suggestion was proposed before and I have cleared the cache on not only on mobile and desktop but aso with cloudflare… I only use 7 plugins and none need to have the cache cleared.

Hi Steven,

We all checked your website and found the posts are loading in all the devices, and shows properly in Mobile. I would request you to provide any screenshot of what exactly you are seeing and please mention the device, browser name and version, and also the operating system you are using, which helps us to replicate the issue at our end.


This is what I am seeing in incognito mode

And in ios mobile

on desktop… its Microsoft edge and the result is the same with Chrome…

Also I would like to mention that I have disabled cloudflare to eliminate this a possible cause of the issue that was a point of concern from one of the first replies

Hi Steven,

This is a cache issue because the latest post is only viewable when we log in on your website. I suggest that you put your website in development mode in your Cloudflare account.

Hope that helps.

Thank you.

I have resolved the issue… Thank you for your assistance

Hi Steven,

Glad that we are able to help you.