PHP Warning per

We have a PHP warning coming from Pro 4.3.3 that floods our logs. It seems to be triggered at every page loading, see below for details.

Illegal string offset ‘custom_css_post_id’

(Can this image be zoomed? Hopefully yes.)

Is it related to the per-page CSS added from the Pro sidebar?

How can we fix this? Thank you for any help or hint you can provide!

Hello @magikweb,

Thanks for writing to us.

It might be the issue of version compatibility. I would suggest you please make sure your theme, plugin, WordPress core, and PHP version is updated as per our version compatibility page.

I would suggest you troubleshoot with a few of the common issues before we investigate your settings.

  1. Testing For Theme Related Issue
  2. Testing For Plugin Conflict
  3. Theme Update
  4. Child Theme
  5. Css/Js Customization
  6. Increasing Php Memory Limit
  7. Disabling Cache
  8. Disabling Cdn
  9. Permalinks
  10. Version Compatibility

If none of those work, It would be best if you could copying your live website to your staging area. and send your details in a secure note so that we can investigate your setting without breaking your live site. Please provide the following details

  • WordPress Login URL
  • Admin level username and password
  • FTP Details

You can find the Secure Note button at the bottom of your posts

Thanks

I’m aware that you have a template that you copy-pasted (to find the issue by elimination), but if a dev could tell us how Cornerstone uses the “custom_css_post_id” (even if vaguely explained), that’d be enough for us.

If it’s impossible, no problem, we’ll get back to the issue later and ask our devs to “find in files” where it’s being used for Pro.

Kind regards,
Vince

Hi Vince,

It will be very difficult to recognize the reason behind the issue through the given screenshot and also the issue was not been replicated. I would request you to go through the common issues provided by my colleague to recognize the reason behind them.

If you have already gone through those, I would request please copy your live site to a staging server and share the credentials if the issue exists on staging.
Alternatively, you can avoid the Warnings by adding the following code into your wp-config.php file as a temporary solution.

define( 'WP_DEBUG', false );

Thanks