Page not editable with Pro - all of a sudden

Hi Rad , thanks.

I started this morning with a clear page - set back-up back from few days ago.
Everything did look good.
First thing I did was: creating templates of every page.

Than I started with creating good links into the coloured blocks - on the English page.
As soon as I saved the page, everything was gone again…

Than I threw away the English home page - in trash and emptied the trash
I created a copy of the Dutch home page to English.
Looking at the ‘back side’ in PRO creator it looks good. But looking on front end I see only the essential grid etc. stuff…

I did try to do this again, but the results are the same… can you please advice?

Hey @lvandeemter,

In Rad’s previous reply, he said switching languages “doesn’t reset any content either (with WPML)” and that is the opposite of what’s happening on your end. There could be something in your server and/or WordPress setup that is causing the issue.

When I opened your Dutch Home Page in the Content Builder and then switched to the English Page using the Flag Icon, the Content Builder (English version) is empty. I tried loading the NL HOME page template in there and I got the saving success message but it actually didn’t save so you still have the testimonial slider in the front-end.

I tested further by creating a new test page. The page I tested was first created in English and then I used the Dutch Flag Icon in the builder and it successfully created the Dutch page however, the issue’s still the same. I’ve edited the Dutch page and the saving success message popped up but it actually didn’t save.

The usual cause of this is caching but factors like low memory could also cause this. Would you mind clearing all caches and completely uninstall your caching plugin. Please contact the caching plugin developer to learn how to do that.

Please also deactivate all third party plugins while we investigate so changes we make will take effect immediately.

Also give us FTP access credentials.


Thank you for your quick reply. I will do so and let you know the information you need.
i come back to you

Thanks for testing. Let us know how it goes.

Hi Christian, I will send you the info in a secure note.

I uninstalled all the plugins - except of the WPML of course. I very much hope you can find something that helps us. We have another website that needs to be translated and I am scared to start with WPML before this issue has been solved.

Thank you so much in advance.

Hey @lvandeemter,

The saving issue was actually caused by 2 factors. The 1st one was caused by a third party plugin and the 2nd was caused by the Essential Grid in your content. Please see my actual investigation in the secure note.

Please activate the third party plugins 1 by 1 to see what plugin was causing the saving issue.

For the Essential Grid conflict, please try going to Ess. Grid > Global Settings and enable JS To Footer. If this does not resolve the issue, please try using The Grid instead.


Thanks for your help!


You’re welcome.

Today I wanted to make some corrections to the website. And I turned from the English to the Dutch language - the home page. Now I see that the Home page of the English site has gone … and turned into the Dutch home page…

Please can you help me again… I am becomming desparate … we need to have this website in the air. But all the time I need to correct / add something the site is giving trouble with the languages.
Thank you in advance

I turned off the Multilangual ACF plugin - that caused a lot of trouble in this theme as it seemd. The Essential Grid Global settings have been changed as you suggested.
But stil I experience difficutlties…

Hey @lvandeemter,

I experienced the issue. This has nothing to do with Essential Grid now because the translation works. The only problem now is editing the default language overrides the other languages too.

Regretfully, this has something to do with the inner workings of Cornerstone (Pro Content Builder). What I could do is post this to our issue tracker to let our development team know of the situation.

For now, a workaround would be to save your page as a template so you won’t lose your page styles. Just do the other language translation once you’re done with the page design.

Please stay tuned for updates.


Thank you Christian,

This is a great shock for me as you will understand. I can only hope your marketing team will explain on front, that this theme is not for multi language websites.

I do not know what to do now. I have to inform my superiors, and they will not be pleased with this answer. Although I appreciate your honesty. A website is something that grows with the business… it should show the heart of it and be able to flow with the changes… Pro cannot do that without loosing former work…

You really leave me in a bit of dispare here.

When a Dutch page is ready for that moment - it is possible of course that the next month it need some changes. Then I loose the English version of it … pfff
Please let the team hurry with a solution!

Since I changed the settings of Essential Grid - with you help / advice - I do not get the grids working again…
Can you please advice what I do wrong?
If I click on - the Dutch Home page - case studies. (see picture) - the grid cannot find the project-page. (nothing changed there)…
Also the product - post pages cannot be found

Hello @lvandeemter,

Please be advise that the grid will no longer display any preview when you are editing the page.
You will only have something like this:

Hope this helps.

Sorry, no that is not what I mean.

I will look into it myself once again and come back to you.

Hi @lvandeemter,

Sure, please let us know.

And about the language overriding the other isn’t a bug, and looks like it’s only specific to your installation. You can check it here and it’s not happening, I tried it on multiple installations too.

I also checked other threads and I don’t see similar issues, the same issue was present on header and footer builder but already fixed, I think last May.

All I could do is recheck it from your installation and see what’s going on. Though have you tried a clean installation of the theme?


Hi Rad, thank you so much for helping out again…

No, I did not try a clean PRO installation.
F.y.i. : this site was originally created with the X-theme and upgrated to PRO. Then we installed the WPML plugin for multi-language and than all this started.

My questions for a trying a clear installations are:

  • can we use the child theme that we have now with the clear installation?
  • do you have a standard step-by-step handout - for this? So I can be sure that I do everything oke?

What do you mean exactly with this: “All I could do is recheck it from your installation and see what’s going on”.

Thanks for you help again.

Hey @lvandeemter,

To your question:

No, please try the parent theme along with a clean install of WordPress with no third party plugins and optimizations such as caching.

Regretfully, we don’t have a tutorial so you must have a back up of your current setup or test in a different environment or server.


Sorry, do I understand it correctly, that you suggest to completely rebuild the website from scratch?

Hello @lvandeemter,

No we didn’t mean by that. I would highly suggest that you go over which page you are having the issue. Please check both the english and the translate page if they are editable in Pro or which one is having a difficulty in editing in Pro. You should be able to edit at least in one of the pages. If everything else fails, you may only rebuild the page from scratch. You can only resort to this usually when you have switched between editors or has corrupted the Pro editor’s data. I doubt this isn’t the case since we were able to edit the page as shown in my previous response.

Hope this helps.

I will try this. Thank you very much.