Old site from 2015 restored, now can't edit any pages


We recently restored an old site that was running on X + Cornerstone.

Something wasn’t working properly, so I purchased Pro and tried to make edits to the front page, but I keep getting 404 errors and I’m not sure what’s going on.

I have already tried all potential solutions found in my previous topic here:

And nothing seems to be working.

I also tried the suggested solutions here:

And I still can’t edit any pages.

We lost the license number for X so we can’t reactivate the old theme so I was hoping there would be a workaround with Pro, which I accidentally purchased instead of X because I thought they were the same thing many months ago.

If there are any ways to work through this, we would appreciate it

Hello Ricardo,

Thanks for writing to us.

In order to help you with your concern, please share your details in a secure note. Please provide the following details

  • WordPress Login URL
  • Admin level username and password

You can find the Secure Note button at the bottom of your posts


Hey Ricardo,

Thank you for providing the credentials. I checked your site and upon editing any page I see the following error:

I checked your WordPress settings and your site is configured with http however your site is loading over https which is the cause of the error (see screenshot)

The troubleshooting steps for this case are as follows:

  • Make sure that if you have HTTPS enabled that you are working in the builder over HTTPS as well.
  • Try deactivating any HTTPS related plugins you have installed
  • Under Settings > General in your dashboard, make sure both the WordPress and Site URL share the same protocol.
  • Consider forcing HTTPS everywhere. If you have the ability to run HTTPS, nowadays it’s just better to use it exclusively. Google claims this will even result in higher indexing.
  • Contact your hosting service provider and ask them for help regarding the case.

You can learn more about builder warnings here https://theme.co/docs/warnings-in-the-builders. I also changed your permalinks from Post name to Plain to fix the 404 errors via WP Admin > Settings > Permalinks

Your site also needs updating, please update WordPress and other outdated plugins as well to avoid conflicts and potential errors.

Let us know how this goes!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.