No Container |Header, Footer option missing + Posts Full Width


Please advise where is this global option located?
Cornerstonr > Click Settings > General > Page Templates > Select Blank No Container Header Footer.

After the update I can see it only under page edit options.

Best Regards,

Hi @kcreative,

Thanks for reaching out.

I am not quite sure what issue you are experiencing, can you explain if further so that we could better help you. Providing a screenshot is a big help.

Thank you.

I cannot find the get icon that used to be on the bottom when I go to appearance --> customize in cornerstone.
From there I was able to change the global page template
e.g. Blank No Container Header Footer.

Now this option is missing and only available on each individual page.
Please advise where I can find this global option.

Best Regards,

Hello Nasko,

There is no page template selector in the X > Settings or Cornerstone > Settings. The page templates are exclusively available to the pages only. For more details about the different page templates in the theme, please check this out:

On the new interface, you can find it in the Gear icon in your WorkSpace navigation:

Hope this helps.

Thank you for your answer.

  1. Then how can I change the Default template option? So I can have it globally for all which “Default” is selected.

And also there is not such option for Posts. How I can change the Template there in order to have no container option?

For instance, I am having that issue with a post - it is displayed with a “container” layout, while all the pages are displayed at “full width”.

  1. How can I have the blog posts display full width as well?

Hello @kcreative,

1.) You can’t set a template for Posts. As I have mentioned in my previous response, it is exclusively available to pages only.

Please be informed that the posts will only depend on the global layout settings in X > Theme Options > Layout and Design > Content Layout.
Screen Shot 2021-01-21 at 9.19.19 AM

2.) Your blog posts are already displaying as fullwidth. It is all because you already have added this custom CSS:

/* Full Width Header Image - Posts */
.single-post .x-container.max.main {
     max-width: 100%;

.single-post .x-container.width.main {
    width: 100%;

.single-post .entry-featured,
.single-post .entry-thumb,
.single-post .entry-featured img {
    width: 100%;

.single-post .entry-wrap {
    max-width: 1200px;
    margin: 0 auto;

Hope this helps.

Thank you for the info, that does help indeed!

You are most welcome @kcreative.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.