Multi-select forms + MacOS + Safari + X Theme = error

Sadly you closed our thread too quick… so here we go again.

The old start posting of our threads describes the problem:
we got customer reports having problems while using Safari on MacOS. We did a lot of debugging and came to the solution that it’s a problem with trying to use multi-select forms on X theme with Safari on MacOS. There are no problems with other browsers or with Safari on Windows.
To exclude cases of custom css or php we tried with X theme “out of the box”: errors persist. We tried with Twenty Nineteen theme: errors gone. We also tried without most of our plugins.

You can see it here using Formidable forms and here using WooCommerce Product Add ons. Remember to use Safari on MacOS and than try to use the multi-select dropdowns.

As an answer to your request I will add login details to our staging for you to take a closer look.

Hi Alexander,

I followed the case using the login information you provided and took the steps below:

  • Disabled all the plugins except Cornerstone.
  • Switched the theme from Child to the Parent theme.
  • Added the X Test Page, and added the Classic Raw Element and a simple select HTML code.
  • Set the Page Template to No Container, No Footer, No Header so that the possibility of the Widget conflict go away.

The result is that the select item is still causing the Safari browser to crash. The next step was to test the case on my local installation, and there is no such error.

The only reason I see this might be happening is the version of the theme. Our latest stable version is 6.5.5 but your theme shows that it is version 6.5.6 which is not yet released. Please kindly go to your Themeco account dashboard and download the stable version of the theme and install it manually as described here.

Just make sure that you rename the x folder to x-old and then install the correct version.

Thank you.


thanks for the really quick answer.

I did what you suggested. Error’s still there and version is still 6.5.6 because the style.css of your actual download for the theme reads:


Theme Name: X
Theme URI:
Author: Themeco
Author URI:
Description: An immensely powerful and endlessly customizable WordPress theme.
Version: 6.5.6
License: GNU General Public License v2.0
License URI: NaN
Text Domain: __x__


Hey Alexander,

We’re sorry for the confusion. 6.5.6 is the latest version of X so that’s not the issue.

I searched for the reason why this happens and this third-party forum is the closest to what is happening in your site.

Based on the thread, though the issue comes from our theme, technically, this is a bug with Safari. Specifically, this has something to do with using a third-party font service like Google Fonts. This is why the Select input works when you switched to the Twenty Nineteen theme because it does not have that setup. In X, I see you’re using a Google Font in Theme Options > Typography.

Would you mind switching to a System Font like Helvetica and make sure nothing in the page uses Google Font just for testing?

Either way though, we can do nothing for this case as this is a browser bug. We could not limit our users to use system fonts only.


1 Like

Thank you, I do think you found the problem!
Switching to Arial (system) and the problem is gone, switching back to Quicksand (Google) and the problem is back. Switching to Proso One (Google) and the problem is gone again. So it seems that Quicksand is the problem here.

Maybe this one or others too (but not all) are causing the problem. Maybe you should try them all and kick the problematic fonts afterwards? Safari is too wide used to have this around in your good theme.

You’re welcome and thank you for further testing other Google fonts.

Regretfully, we could not remove the Google Fonts as they’re not the cause of the issue. This is a bug in Safari and should be fixed by their developers as this is not only an issue with Google Fonts. It happens in other font service providers as well.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.